Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.0.0
    • Component/s: io, wal
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      As we have moved to jdk8, and dropped the support of hadoop-2.4.x and hadoop-2.5.x on master, we could use CompletableFuture instead of CompletionHandler to make the code more clear, and also remove the support of hadoop-2.4.x and hadoop-2.5.x to remove lots of the reflection code.

        Attachments

        1. HBASE-16968.patch
          115 kB
          Duo Zhang
        2. HBASE-16968-v1.patch
          121 kB
          Duo Zhang

          Issue Links

            Activity

              People

              • Assignee:
                zhangduo Duo Zhang
                Reporter:
                zhangduo Duo Zhang
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: