Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-8417

HADOOP-6963 didn't update hadoop-core-pom-template.xml

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.3
    • Fix Version/s: 1.1.0
    • Component/s: None
    • Labels:
      None

      Description

      HADOOP-6963 introduced commons-io 2.1 in ivy.xml but forgot to update the hadoop-core-pom-template.xml.

      This has caused map reduce jobs in downstream projects to fail with:

      Caused by: java.lang.ClassNotFoundException: org.apache.commons.io.FileUtils
      	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      	... 15 more
      

      This caused a regression for 1.0.3 because downstream projects used to not directly depend on commons-io

        Attachments

        1. hadoop-8417.txt
          0.6 kB
          Ted Yu
        2. hadoop-8417-v2.txt
          1 kB
          Ted Yu

          Activity

            People

            • Assignee:
              zhihyu@ebaysf.com Ted Yu
              Reporter:
              zhihyu@ebaysf.com Ted Yu
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: