Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-7470

move up to Jackson 1.8.8

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 0.20.203.0
    • 1.0.1, 0.23.1
    • util
    • None
    • Incompatible change, Reviewed

    Description

      I see that hadoop-core still depends on Jackson 1.0.1 -but that project is now up to 1.8.2 in releases. Upgrading will make it easier for other Jackson-using apps that are more up to date to keep their classpath consistent.

      The patch would be updating the ivy file to pull in the later version; no test

      Attachments

        1. hadoop-trunk-jackson_v1.patch
          0.9 kB
          Enis Soztutar
        2. hadoop-1.0-jackson_v1.patch
          2 kB
          Enis Soztutar

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            enis Enis Soztutar
            stevel@apache.org Steve Loughran
            Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - 0.25h
                0.25h
                Remaining:
                Remaining Estimate - 0.25h
                0.25h
                Logged:
                Time Spent - Not Specified
                Not Specified

                Issue deployment