Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-9055

POM files for hadoop-core 1.x should depend on Jackson 1.8.8

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.0.0, 1.1.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      According to this: https://issues.apache.org/jira/browse/HADOOP-7470

      Jackson has been upgraded to 1.8.8, but the POMs on the apache maven repo for the hadoop 1.x line still specify 1.0.1 for the library. That's causing build problems for hive (which uses 1.0.0 to build its 20S shim).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gkesavan Giridharan Kesavan
                Reporter:
                hagleitn Gunther Hagleitner
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: