Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.20.0
    • Fix Version/s: 0.20.1
    • Component/s: util
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      GenericOptionsParser in branch 0.20 depends on commons-cli2. This jira removes the dependency of branch 0.20 on commons-cli2 completely. The problem is seen after 'ant binary' where all the library files are copied to '$hadoop-home/lib' which already has commons-cli2.
      Show
      GenericOptionsParser in branch 0.20 depends on commons-cli2. This jira removes the dependency of branch 0.20 on commons-cli2 completely. The problem is seen after 'ant binary' where all the library files are copied to '$hadoop-home/lib' which already has commons-cli2.

      Description

      GenericOptionsParser depends on commons-cli2

        Issue Links

          Activity

          Amar Kamat added a comment -

          Attaching a patch that removes the dependency on GenericOptionsParser on commons-cli2.
          [exec] -1 overall.
          [exec]
          [exec] +1 @author. The patch does not contain any @author tags.
          [exec]
          [exec] -1 tests included. The patch doesn't appear to include any new or modified tests.
          [exec] Please justify why no tests are needed for this patch.
          [exec]
          [exec] +1 javadoc. The javadoc tool did not generate any warning messages.
          [exec]
          [exec] +1 javac. The applied patch does not increase the total number of javac compiler warnings.
          [exec]
          [exec] +1 findbugs. The patch does not introduce any new Findbugs warnings.
          [exec]
          [exec] -1 Eclipse classpath. The patch causes the Eclipse classpath to differ from the contents of the lib directories.

          Eclipse classpath check fails because commons-cli2 has to be manually deleted.

          Running ant tests.

          Sharad Agarwal added a comment -

          The fix is the backport of HADOOP-5896 to 0.20

          Amar Kamat added a comment -

          All test except TestDistributedFileSystem and TestReduceFetch passed. Testing contrib now.

          Amar Kamat added a comment -

          TestStreamingWithExitStatus, TestJobInitialization (timeout) and TestQueueCapacities (timeout) failed in contrib.

          Sharad Agarwal added a comment -

          I just committed this. Thanks Amar!

          Owen O'Malley added a comment -

          We missed the split("=", 2) here...

          Owen O'Malley added a comment -

          Opened a new jira HADOOP-6215 to resolve the issue in trunk and 0.20.


            People

            • Assignee:
              Amar Kamat
              Reporter:
              Amar Kamat
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development