Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-15882

Upgrade maven-shade-plugin from 2.4.3 to 3.2.0

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2.0, 3.0.4, 3.3.0, 3.1.2
    • Component/s: None
    • Labels:
      None

      Description

      While working on HADOOP-15815, we have faced a shaded-client error. Please see Bharat Viswanadham's comment here.

      MSHADE-242 and MSHADE-258 are needed to fix it. Let's upgrade maven-shade-plugin to 3.1.0 or later.
       

        Attachments

        1. HADOOP-15882.1.patch
          1 kB
          Takanobu Asanuma

          Issue Links

            Activity

              People

              • Assignee:
                tasanuma Takanobu Asanuma
                Reporter:
                tasanuma Takanobu Asanuma
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: