Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4.3
    • Fix Version/s: 3.1.0
    • Labels:
      None
    • Environment:
      ╰─✘ java -version
      openjdk version "9-internal"
      OpenJDK Runtime Environment (build 9-internal+0-2016-11-17-101644.norman.jdk9)
      OpenJDK 64-Bit Server VM (build 9-internal+0-2016-11-17-101644.norman.jdk9, mixed mode)

      Description

      When trying to use the shade plugin with java9 I get:

      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-shade-plugin:2.4.3:shade (default) on project netty-common: Error creating shaded jar: null: IllegalArgumentException -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-shade-plugin:2.4.3:shade (default) on project netty-common: Error creating shaded jar: null
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
      	at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
      	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
      	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
      	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.base/java.lang.reflect.Method.invoke(Method.java:537)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
      Caused by: org.apache.maven.plugin.MojoExecutionException: Error creating shaded jar: null
      	at org.apache.maven.plugins.shade.mojo.ShadeMojo.execute(ShadeMojo.java:540)
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
      	... 20 more
      Caused by: java.lang.IllegalArgumentException
      	at org.objectweb.asm.ClassReader.<init>(Unknown Source)
      	at org.objectweb.asm.ClassReader.<init>(Unknown Source)
      	at org.objectweb.asm.ClassReader.<init>(Unknown Source)
      	at org.vafer.jdependency.Clazzpath.addClazzpathUnit(Clazzpath.java:201)
      	at org.vafer.jdependency.Clazzpath.addClazzpathUnit(Clazzpath.java:132)
      	at org.apache.maven.plugins.shade.filter.MinijarFilter.<init>(MinijarFilter.java:94)
      	at org.apache.maven.plugins.shade.mojo.ShadeMojo.getFilters(ShadeMojo.java:814)
      	at org.apache.maven.plugins.shade.mojo.ShadeMojo.execute(ShadeMojo.java:446)
      	... 22 more
      

        Issue Links

          Activity

          gboue Guillaume Boué added a comment -

          This is an issue with ASM 5.1 that the plugin uses, which doesn't have support for Java 9 at the moment. There is an alpha version 6.0_ALPHA that should have support, so it could work by forcing the usage of this version in the plugin's dependencies. You'll need a dependency on asm, asm-commons, asm-analysis and asm-util in that version (group id is org.ow2.asm).

          norman Norman Maurer added a comment -

          This works, thanks! I guess we should still keep the issue open tho ?

          gboue Guillaume Boué added a comment -

          Yes, better to track this, because the version update of ASM used in the plugin will need to be performed. Most likely when a final version of 6.0 will be available.

          norman Norman Maurer added a comment -

          Just ping if you need anything else. And thanks again

          headius Charles Oliver Nutter added a comment -

          No update for this yet? Prevents building any project using the shade plugin on Java 9.

          rfscholte Robert Scholte added a comment -

          Still waiting for the next ASM release, 6.0_ALPHA is not compatible with the current module-info.class implementation anymore.

          Don-vip Vincent Privat added a comment -
          Don-vip Vincent Privat added a comment -

          and now available on Maven Central: http://repo1.maven.org/maven2/org/ow2/asm/asm/6.0_BETA/

          rfscholte Robert Scholte added a comment -

          So we're one step closer. First jdependency needs to do some stuff before we can upgrade.

          rfscholte Robert Scholte added a comment -

          Fixed in r1805501

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-plugins #9072 (See https://builds.apache.org/job/maven-plugins/9072/)
          MSHADE-242 Plugin does not work with Java 9
          Upgraded ASM + JDependency
          Adjust code due to dependency upgrades (rfscholte: http://svn.apache.org/viewvc/?view=rev&rev=1805501)

          • (edit) maven-shade-plugin/pom.xml
          • (edit) maven-shade-plugin/src/main/java/org/apache/maven/plugins/shade/DefaultShader.java
          • (edit) maven-shade-plugin/src/main/java/org/apache/maven/plugins/shade/filter/MinijarFilter.java

            People

            • Assignee:
              rfscholte Robert Scholte
              Reporter:
              norman Norman Maurer
            • Votes:
              2 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development