Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-14502

Confusion/name conflict between NameNodeActivity#BlockReportNumOps and RpcDetailedActivity#BlockReportNumOps



    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0-alpha4
    • Component/s: metrics
    • Labels:
    • Target Version/s:
    • Hadoop Flags:
      Incompatible change, Reviewed
    • Release Note:
      Remove the BlockReport(NumOps,AvgTime) metrics emitted under the NameNodeActivity context in favor of StorageBlockReport(NumOps,AvgTime) which more accurately represent the metric. Same for the corresponding quantile metrics.


      Currently the BlockReport(NumOps|AvgTime) metrics emitted under the RpcDetailedActivity context and those emitted under the NameNodeActivity context are actually reporting different things despite having the same name. NameNodeActivity reports the count/time of per storage block reports, whereas RpcDetailedActivity reports the count/time of per datanode block reports. This makes for a confusing experience with two metrics having the same name reporting different values.

      We already have the StorageBlockReportsOps metric under NameNodeActivity. Can we make StorageBlockReport a MutableRate metric and remove NameNodeActivity#BlockReport metric? Open to other suggestions about how to address this as well. The 3.0 release seems a good time to make this incompatible change.


        1. HADOOP-14502.000.patch
          6 kB
          Erik Krogen
        2. HADOOP-14502.001.patch
          7 kB
          Erik Krogen
        3. HADOOP-14502.002.patch
          7 kB
          Erik Krogen

          Issue Links



              • Assignee:
                xkrogen Erik Krogen
                xkrogen Erik Krogen
              • Votes:
                0 Vote for this issue
                5 Start watching this issue


                • Created: