Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-12649 Improve Kerberos diagnostics and failure handling
  3. HADOOP-12913

Drop the @LimitedPrivate maker off UGI, as its clearly untrue

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.8.0
    • Fix Version/s: None
    • Component/s: security
    • Labels:
      None

      Description

      UGI declares itself as

      {@InterfaceAudience.LimitedPrivate({"HDFS", "MapReduce", "HBase", "Hive", "Oozie"})
      

      Really its "any application that interacts with services in a secure cluster".

      I propose: replace with @Public, @Evolving

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                stevel@apache.org Steve Loughran
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: