Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-12714

Fix hadoop-mapreduce-client-nativetask unit test which fails because it is not able to open the "glibc bug spill" file.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: native
    • Labels:
      None
    • Target Version/s:

      Description

      Fix hadoop-mapreduce-client-nativetask unit test which fails because it is not able to open the "glibc bug spill" file.

      1. HADOOP-12714.002.patch
        2 kB
        Colin P. McCabe
      2. HADOOP-12714.001.patch
        0.8 kB
        Colin P. McCabe

        Issue Links

          Activity

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 7m 30s trunk passed
          +1 compile 0m 44s trunk passed with JDK v1.8.0_66
          -1 compile 0m 29s hadoop-mapreduce-client-nativetask in trunk failed with JDK v1.7.0_91.
          +1 mvnsite 0m 21s trunk passed
          +1 mvneclipse 0m 11s trunk passed
          +1 mvninstall 0m 15s the patch passed
          -1 compile 0m 30s hadoop-mapreduce-client-nativetask in the patch failed with JDK v1.8.0_66.
          -1 cc 0m 30s hadoop-mapreduce-client-nativetask in the patch failed with JDK v1.8.0_66.
          -1 javac 0m 30s hadoop-mapreduce-client-nativetask in the patch failed with JDK v1.8.0_66.
          +1 compile 0m 42s the patch passed with JDK v1.7.0_91
          +1 cc 0m 42s the patch passed
          -1 javac 10m 53s hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.7.0_91 with JDK v1.7.0_91 generated 1 new issues (was 0, now 1).
          +1 javac 0m 42s the patch passed
          +1 mvnsite 0m 17s the patch passed
          +1 mvneclipse 0m 10s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          -1 unit 0m 57s hadoop-mapreduce-client-nativetask in the patch failed with JDK v1.8.0_66.
          -1 unit 0m 28s hadoop-mapreduce-client-nativetask in the patch failed with JDK v1.7.0_91.
          +1 asflicense 0m 16s Patch does not generate ASF License warnings.
          13m 11s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12782398/HADOOP-12714.001.patch
          JIRA Issue HADOOP-12714
          Optional Tests asflicense compile cc mvnsite javac unit
          uname Linux afa5b3db6f74 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / cdf8895
          Default Java 1.7.0_91
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
          compile https://builds.apache.org/job/PreCommit-HADOOP-Build/8413/artifact/patchprocess/branch-compile-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.7.0_91.txt
          compile https://builds.apache.org/job/PreCommit-HADOOP-Build/8413/artifact/patchprocess/patch-compile-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.8.0_66.txt
          cc https://builds.apache.org/job/PreCommit-HADOOP-Build/8413/artifact/patchprocess/patch-compile-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.8.0_66.txt
          javac https://builds.apache.org/job/PreCommit-HADOOP-Build/8413/artifact/patchprocess/patch-compile-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.8.0_66.txt
          javac hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.7.0_91: https://builds.apache.org/job/PreCommit-HADOOP-Build/8413/artifact/patchprocess/diff-compile-javac-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.7.0_91.txt
          unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8413/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8413/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/8413/testReport/
          modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-nativetask U: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-nativetask
          Max memory used 76MB
          Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/8413/console

          This message was automatically generated.

          andrew.wang Andrew Wang added a comment -

          Based on my understanding of the test, we've checked in a test file which, when read, reproduces this glibc bug. That file should always be present though, if it's not we have some problem finding test resources.

          cmccabe Colin P. McCabe added a comment -

          Ah, good catch. I assumed this was a file generated by glibc (since it's named "testGlibCBugSpill"), but actually it's a (very large) resource checked into the source tree. It looks like it gets copied from ./hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-nativetask/src/main/native/testData/testGlibCBugSpill to ./hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-nativetask/target/native/test/testData/testGlibCBugSpill as part of the build process. It wasn't being found because the cmakebuilder plugin was running the test with the wrong working directory. I added a fix for this in v2.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          0 mvndep 0m 28s Maven dependency ordering for branch
          +1 mvninstall 7m 41s trunk passed
          -1 compile 5m 5s root in trunk failed with JDK v1.8.0_66.
          -1 compile 5m 27s root in trunk failed with JDK v1.7.0_91.
          +1 checkstyle 0m 59s trunk passed
          +1 mvnsite 0m 35s trunk passed
          +1 mvneclipse 0m 24s trunk passed
          +1 findbugs 0m 52s trunk passed
          -1 javadoc 0m 11s hadoop-maven-plugins in trunk failed with JDK v1.8.0_66.
          +1 javadoc 0m 27s trunk passed with JDK v1.7.0_91
          0 mvndep 0m 14s Maven dependency ordering for patch
          +1 mvninstall 0m 26s the patch passed
          +1 compile 5m 54s the patch passed with JDK v1.8.0_66
          -1 javac 6m 35s root-jdk1.8.0_66 with JDK v1.8.0_66 generated 156 new issues (was 576, now 732).
          +1 javac 5m 54s the patch passed
          -1 compile 5m 19s root in the patch failed with JDK v1.7.0_91.
          -1 javac 5m 19s root in the patch failed with JDK v1.7.0_91.
          +1 checkstyle 0m 58s the patch passed
          +1 mvnsite 0m 36s the patch passed
          +1 mvneclipse 0m 24s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 xml 0m 0s The patch has no ill-formed XML file.
          +1 findbugs 1m 6s the patch passed
          -1 javadoc 0m 11s hadoop-maven-plugins in the patch failed with JDK v1.8.0_66.
          +1 javadoc 0m 28s the patch passed with JDK v1.7.0_91
          +1 unit 0m 12s hadoop-maven-plugins in the patch passed with JDK v1.8.0_66.
          -1 unit 8m 28s hadoop-mapreduce-client-nativetask in the patch failed with JDK v1.8.0_66.
          +1 unit 0m 14s hadoop-maven-plugins in the patch passed with JDK v1.7.0_91.
          -1 unit 9m 41s hadoop-mapreduce-client-nativetask in the patch failed with JDK v1.7.0_91.
          +1 asflicense 0m 25s Patch does not generate ASF License warnings.
          58m 35s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12782551/HADOOP-12714.002.patch
          JIRA Issue HADOOP-12714
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml findbugs checkstyle
          uname Linux d680764283ab 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / fc6d3a3
          Default Java 1.7.0_91
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
          compile https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/artifact/patchprocess/branch-compile-root-jdk1.8.0_66.txt
          compile https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/artifact/patchprocess/branch-compile-root-jdk1.7.0_91.txt
          findbugs v3.0.0
          javadoc https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/artifact/patchprocess/branch-javadoc-hadoop-maven-plugins-jdk1.8.0_66.txt
          javac root-jdk1.8.0_66: https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/artifact/patchprocess/diff-compile-javac-root-jdk1.8.0_66.txt
          compile https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/artifact/patchprocess/patch-compile-root-jdk1.7.0_91.txt
          javac https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/artifact/patchprocess/patch-compile-root-jdk1.7.0_91.txt
          javadoc https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/artifact/patchprocess/patch-javadoc-hadoop-maven-plugins-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/testReport/
          modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-nativetask hadoop-maven-plugins U: .
          Max memory used 76MB
          Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/8417/console

          This message was automatically generated.

          andrew.wang Andrew Wang added a comment -

          Precommit thinks the native build failed, and some native test is broken.

          cmccabe Colin P. McCabe added a comment -

          The native build did fail, with:

          [WARNING] /usr/bin/cmake: error while loading shared libraries: libxml2.so.2: failed to map segment from shared object: Permission denied
          

          This doesn't have anything to do with the patch. I will re-trigger the build.

          andrew.wang Andrew Wang added a comment -

          I'll +1 since the failures do not seem related to this change, but it does seem possibly related to the CMake plugin, so we need to trace this down.

          cmccabe Colin P. McCabe added a comment -

          Filed YETUS-286 for the "failed to map segment" failures. Thanks for the reviews!

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          0 mvndep 0m 15s Maven dependency ordering for branch
          +1 mvninstall 7m 34s trunk passed
          +1 compile 6m 18s trunk passed with JDK v1.8.0_66
          +1 compile 6m 59s trunk passed with JDK v1.7.0_91
          +1 checkstyle 1m 1s trunk passed
          +1 mvnsite 0m 36s trunk passed
          +1 mvneclipse 0m 24s trunk passed
          +1 findbugs 0m 55s trunk passed
          -1 javadoc 0m 12s hadoop-maven-plugins in trunk failed with JDK v1.8.0_66.
          +1 javadoc 0m 26s trunk passed with JDK v1.7.0_91
          0 mvndep 0m 15s Maven dependency ordering for patch
          +1 mvninstall 0m 27s the patch passed
          -1 compile 0m 35s root in the patch failed with JDK v1.8.0_66.
          -1 javac 0m 35s root in the patch failed with JDK v1.8.0_66.
          -1 compile 0m 44s root in the patch failed with JDK v1.7.0_91.
          -1 javac 0m 44s root in the patch failed with JDK v1.7.0_91.
          +1 checkstyle 1m 2s the patch passed
          +1 mvnsite 0m 32s the patch passed
          +1 mvneclipse 0m 19s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 xml 0m 1s The patch has no ill-formed XML file.
          +1 findbugs 1m 2s the patch passed
          -1 javadoc 0m 9s hadoop-maven-plugins in the patch failed with JDK v1.8.0_66.
          +1 javadoc 0m 22s the patch passed with JDK v1.7.0_91
          +1 unit 0m 10s hadoop-maven-plugins in the patch passed with JDK v1.8.0_66.
          -1 unit 0m 48s hadoop-mapreduce-client-nativetask in the patch failed with JDK v1.8.0_66.
          +1 unit 0m 10s hadoop-maven-plugins in the patch passed with JDK v1.7.0_91.
          -1 unit 0m 55s hadoop-mapreduce-client-nativetask in the patch failed with JDK v1.7.0_91.
          +1 asflicense 0m 19s Patch does not generate ASF License warnings.
          34m 14s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12782551/HADOOP-12714.002.patch
          JIRA Issue HADOOP-12714
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml findbugs checkstyle
          uname Linux f13a6195df2a 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 5d5a22a
          Default Java 1.7.0_91
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_66 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_91
          findbugs v3.0.0
          javadoc https://builds.apache.org/job/PreCommit-HADOOP-Build/8420/artifact/patchprocess/branch-javadoc-hadoop-maven-plugins-jdk1.8.0_66.txt
          compile https://builds.apache.org/job/PreCommit-HADOOP-Build/8420/artifact/patchprocess/patch-compile-root-jdk1.8.0_66.txt
          javac https://builds.apache.org/job/PreCommit-HADOOP-Build/8420/artifact/patchprocess/patch-compile-root-jdk1.8.0_66.txt
          compile https://builds.apache.org/job/PreCommit-HADOOP-Build/8420/artifact/patchprocess/patch-compile-root-jdk1.7.0_91.txt
          javac https://builds.apache.org/job/PreCommit-HADOOP-Build/8420/artifact/patchprocess/patch-compile-root-jdk1.7.0_91.txt
          javadoc https://builds.apache.org/job/PreCommit-HADOOP-Build/8420/artifact/patchprocess/patch-javadoc-hadoop-maven-plugins-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8420/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-HADOOP-Build/8420/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-nativetask-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/8420/testReport/
          modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-nativetask hadoop-maven-plugins U: .
          Max memory used 76MB
          Powered by Apache Yetus 0.2.0-SNAPSHOT http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/8420/console

          This message was automatically generated.

          cmccabe Colin P. McCabe added a comment -

          Committed to trunk, thanks!

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #9125 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9125/)
          HADOOP-12714. Fix hadoop-mapreduce-client-nativetask unit test which (cmccabe: rev 5af5f9575a906324e5a6ca442217bdaa8ec42fa0)

          • hadoop-maven-plugins/src/main/java/org/apache/hadoop/maven/plugin/cmakebuilder/TestMojo.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-nativetask/pom.xml

            People

            • Assignee:
              cmccabe Colin P. McCabe
              Reporter:
              cmccabe Colin P. McCabe
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development