Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-11090 [Umbrella] Support Java 8 in Hadoop
  3. HADOOP-11993

maven enforcer plugin to ban java 8 incompatible dependencies

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.7.0
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None

      Description

      It's possible to use maven-enforcer to ban dependencies; this can be used to reject those known to be incompatible with Java 8

      example

      If we set maven enforcer to do this checking, it can ensure that the 2.7+ codebase isn't pulling in any incompatible binaries.

        Attachments

        1. HADOOP-11993.001.patch
          2 kB
          Tsuyoshi Ozawa
        2. HADOOP-11993.002.patch
          2 kB
          Tsuyoshi Ozawa

          Issue Links

            Activity

              People

              • Assignee:
                ozawa Tsuyoshi Ozawa
                Reporter:
                stevel@apache.org Steve Loughran
              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: