Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: None
    • Target Version/s:
    • Hadoop Flags:
      Incompatible change, Reviewed
    • Release Note:
      Upgrading following dependences:
      * Guice from 3.0 to 4.0
      * cglib from 2.2 to 3.2.0
      * asm from 3.2 to 5.0.4
      Show
      Upgrading following dependences: * Guice from 3.0 to 4.0 * cglib from 2.2 to 3.2.0 * asm from 3.2 to 5.0.4

      Description

      guice 3.0 doesn't work with lambda statement. https://github.com/google/guice/issues/757

      We should upgrade it to 4.0 which includes the fix.

      1. HADOOP-12064.001.patch
        0.9 kB
        Tsuyoshi Ozawa
      2. HADOOP-12064.002.WIP.patch
        1 kB
        Tsuyoshi Ozawa
      3. HADOOP-12064.002.patch
        1 kB
        Tsuyoshi Ozawa

        Issue Links

          Activity

          pgaref Panagiotis Garefalakis added a comment -

          Tsuyoshi Ozawa its been a while and I did not face the issue again so I agree it must have been a maven issue indeed.

          Cheers,
          Panagiotis

          ozawa Tsuyoshi Ozawa added a comment - - edited

          I cannot reproduce the problem. I think above error reported by Panagiotis Garefalakis can be fixed after removing ~/.m2 directory.

          ozawa Tsuyoshi Ozawa added a comment -

          Panagiotis Garefalakis Thanks for the reporting. It looks strange to me since it exists in Guice 4.0. Anyway, I will check it on my local.

          https://github.com/google/guice/blob/4.0/core/src/com/google/inject/Scopes.java#L184

          pgaref Panagiotis Garefalakis added a comment -

          Guice-4.0 is breaking resourceManager webapp interface ( check exception below ). After rolling back to guice3.0 the exception disappears.

          Problem accessing /cluster/scheduler. Reason:
          com.google.inject.Scopes.isCircularProxy(Ljava/lang/Object;)Z

          Caused by:
          java.lang.NoSuchMethodError: com.google.inject.Scopes.isCircularProxy(Ljava/lang/Object;)Z
          at com.google.inject.servlet.ServletScopes$1$1.get(ServletScopes.java:123)
          at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:40)
          at com.google.inject.internal.InjectorImpl$4$1.call(InjectorImpl.java:978)
          at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1024)
          at com.google.inject.internal.InjectorImpl$4.get(InjectorImpl.java:974)
          at com.google.inject.internal.InjectorImpl.getInstance(InjectorImpl.java:1013)
          at org.apache.hadoop.yarn.webapp.Dispatcher.service(Dispatcher.java:119)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
          at com.google.inject.servlet.ServletDefinition.doServiceImpl(ServletDefinition.java:287)
          at com.google.inject.servlet.ServletDefinition.doService(ServletDefinition.java:277)
          at com.google.inject.servlet.ServletDefinition.service(ServletDefinition.java:182)
          at com.google.inject.servlet.ManagedServletPipeline.service(ManagedServletPipeline.java:91)
          at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:941)
          at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:875)
          at org.apache.hadoop.yarn.server.resourcemanager.webapp.RMWebAppFilter.doFilter(RMWebAppFilter.java:178)
          at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:829)
          at com.google.inject.servlet.ManagedFilterPipeline.dispatch(ManagedFilterPipeline.java:119)
          at com.google.inject.servlet.GuiceFilter$1.call(GuiceFilter.java:133)
          at com.google.inject.servlet.GuiceFilter$1.call(GuiceFilter.java:130)
          at com.google.inject.servlet.GuiceFilter$Context.call(GuiceFilter.java:203)
          at com.google.inject.servlet.GuiceFilter.doFilter(GuiceFilter.java:130)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
          at org.apache.hadoop.security.http.XFrameOptionsFilter.doFilter(XFrameOptionsFilter.java:57)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
          at org.apache.hadoop.http.lib.StaticUserWebFilter$StaticUserFilter.doFilter(StaticUserWebFilter.java:109)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
          at org.apache.hadoop.security.authentication.server.AuthenticationFilter.doFilter(AuthenticationFilter.java:606)
          at org.apache.hadoop.security.token.delegation.web.DelegationTokenAuthenticationFilter.doFilter(DelegationTokenAuthenticationFilter.java:294)
          at org.apache.hadoop.security.authentication.server.AuthenticationFilter.doFilter(AuthenticationFilter.java:558)
          at org.apache.hadoop.yarn.server.security.http.RMAuthenticationFilter.doFilter(RMAuthenticationFilter.java:82)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
          at org.apache.hadoop.http.HttpServer2$QuotingInputFilter.doFilter(HttpServer2.java:1243)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
          at org.apache.hadoop.http.NoCacheFilter.doFilter(NoCacheFilter.java:45)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
          at org.apache.hadoop.http.NoCacheFilter.doFilter(NoCacheFilter.java:45)
          at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
          at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:399)
          at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
          at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
          at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
          at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:450)
          at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
          at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
          at org.mortbay.jetty.Server.handle(Server.java:326)
          at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)
          at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:928)
          at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:549)
          at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)
          at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
          at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:410)
          at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)

          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-trunk-Commit #10043 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10043/)
          HADOOP-12064. [JDK8] Update guice version to 4.0. (ozawa) (ozawa: rev 4009fa3a9272ddfe3825b1bd61b3ab9dc0124050)

          • hadoop-project/pom.xml
          ozawa Tsuyoshi Ozawa added a comment -

          Committed this to trunk. Again, thanks for your review, Akira!

          ozawa Tsuyoshi Ozawa added a comment - - edited

          Thanks Akira Ajisaka for your review. Checking this in trunk based on your review and discussion on the mailing list.

          ajisakaa Akira Ajisaka added a comment -

          LGTM, +1. I ran mvn test -Dtest=*Web* and all the tests passed.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 23s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 1s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 7m 8s trunk passed
          +1 compile 0m 10s trunk passed
          +1 mvnsite 0m 11s trunk passed
          +1 mvneclipse 0m 10s trunk passed
          +1 javadoc 0m 10s trunk passed
          +1 mvninstall 0m 7s the patch passed
          +1 compile 0m 6s the patch passed
          +1 javac 0m 6s the patch passed
          +1 mvnsite 0m 8s the patch passed
          +1 mvneclipse 0m 7s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 xml 0m 2s The patch has no ill-formed XML file.
          +1 javadoc 0m 7s the patch passed
          +1 unit 0m 6s hadoop-project in the patch passed.
          +1 asflicense 0m 16s The patch does not generate ASF License warnings.
          9m 42s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:e2f6409
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12812110/HADOOP-12064.002.patch
          JIRA Issue HADOOP-12064
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml
          uname Linux 2b73f254da60 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 46f1602
          Default Java 1.8.0_91
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/9843/testReport/
          modules C: hadoop-project U: hadoop-project
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9843/console
          Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          ozawa Tsuyoshi Ozawa added a comment -

          Rebasing v2 patch on trunk.

          ajisakaa Akira Ajisaka added a comment -

          Hence, I prefer 4.0.0 to 4.1.0 at this point.

          Agreed.

          ozawa Tsuyoshi Ozawa added a comment -

          I surveyed whether Guice 4.1.0 is acceptable for Hadoop: the answer is we cannot upgrade Guice 4.1.0 because it uses Guava 19.0.0. On the other hand, Guice 4.0.0 uses Guava 16.0.1, which is acceptable version for Hadoop for now.

          Hence, I prefer 4.0.0 to 4.1.0 at this point.

          ozawa Tsuyoshi Ozawa added a comment -

          OK, I will check whether the upgrading to 4.1 is acceptable.

          ajisakaa Akira Ajisaka added a comment -

          Guice 4.1 has been released, so can we move to 4.1 instead of 4.0?

          ozawa Tsuyoshi Ozawa added a comment -

          Kicking the Jenkins with 002 patch. I'll test the patch with on my local.

          ozawa Tsuyoshi Ozawa added a comment -

          Fortunately, mvn test -Dtest="Test*Web*" passed on my local. I'll be back here after merging HADOOP-9613 into trunk and checking jdiff between guice 4.0 and 3.0.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 12s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 8m 37s trunk passed
          +1 compile 0m 9s trunk passed with JDK v1.8.0_91
          +1 compile 0m 10s trunk passed with JDK v1.7.0_95
          +1 mvnsite 0m 13s trunk passed
          +1 mvneclipse 0m 12s trunk passed
          +1 javadoc 0m 11s trunk passed with JDK v1.8.0_91
          +1 javadoc 0m 10s trunk passed with JDK v1.7.0_95
          +1 mvninstall 0m 9s the patch passed
          +1 compile 0m 7s the patch passed with JDK v1.8.0_91
          +1 javac 0m 7s the patch passed
          +1 compile 0m 7s the patch passed with JDK v1.7.0_95
          +1 javac 0m 7s the patch passed
          +1 mvnsite 0m 11s the patch passed
          +1 mvneclipse 0m 8s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 xml 0m 1s The patch has no ill-formed XML file.
          +1 javadoc 0m 8s the patch passed with JDK v1.8.0_91
          +1 javadoc 0m 9s the patch passed with JDK v1.7.0_95
          +1 unit 0m 7s hadoop-project in the patch passed with JDK v1.8.0_91.
          +1 unit 0m 7s hadoop-project in the patch passed with JDK v1.7.0_95.
          +1 asflicense 0m 22s The patch does not generate ASF License warnings.
          12m 29s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:cf2ee45
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12803438/HADOOP-12064.002.WIP.patch
          JIRA Issue HADOOP-12064
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit xml
          uname Linux 5015920bdfd4 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 39f2bac
          Default Java 1.7.0_95
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_91 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
          JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/9369/testReport/
          modules C: hadoop-project U: hadoop-project
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9369/console
          Powered by Apache Yetus 0.3.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          ozawa Tsuyoshi Ozawa added a comment -

          Attached WIP patch for my local testing. I'll run all tests and check what it will happen.

          busbey Sean Busbey added a comment -

          linking the jdiff from the release notes for 4.0. (wise move, Steve.)

          ozawa Tsuyoshi Ozawa added a comment -

          Good catch. Thank you for marking the flag, Steve.

          stevel@apache.org Steve Loughran added a comment -

          given this a google JAR, its probably going to break everything and be incredibly traumatic. I'm going to flag it as incompatible as default, based on past experience

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 14m 34s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 javac 7m 34s There were no new javac warning messages.
          +1 javadoc 9m 42s There were no new javadoc warning messages.
          +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 34s mvn install still works.
          +1 eclipse:eclipse 0m 36s The patch built with eclipse:eclipse.
              34m 27s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12737671/HADOOP-12064.001.patch
          Optional Tests javadoc javac unit
          git revision trunk / 9f6d678
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/6925/testReport/
          Java 1.7.0_55
          uname Linux asf907.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/6925/console

          This message was automatically generated.

          ozawa Tsuyoshi Ozawa added a comment -

          Attaching a first patch.


            People

            • Assignee:
              ozawa Tsuyoshi Ozawa
              Reporter:
              ozawa Tsuyoshi Ozawa
            • Votes:
              1 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development