Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-11523

StorageException complaining " no lease ID" when updating FolderLastModifiedTime in WASB

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.7.0
    • Component/s: tools
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      In current WASB (Windows Azure Storage - Blob) implementation, when rename operation succeeds, WASB will update the parent folder's "last modified time" property. By default we do not acquire lease on this folder when updating its property and simply pass "null" to it.

      In HBase scenario, when doing distributed log splitting, there might be a case that multiple processes from different region servers will access the same folder, and randomly we will see this exception in regionserver's log, which makes log splitting fail.

      So we should acquire the lease when updating the folder property rather than pass "null" to it.

      ERROR org.apache.hadoop.hbase.regionserver.wal.HLogSplitter: Couldn't rename wasb://xxx/hbase/data/default/tdelrowtbl/3c842e8823c192d1028dc72ac3f22886/recovered.edits/0000000000000000015.temp to wasb://xxx/hbase/data/default/tdelrowtbl/3c842e8823c192d1028dc72ac3f22886/recovered.edits/0000000000000000015
      org.apache.hadoop.fs.azure.AzureException: com.microsoft.windowsazure.storage.StorageException: There is currently a lease on the blob and no lease ID was specified in the request.
      	at org.apache.hadoop.fs.azurenative.AzureNativeFileSystemStore.updateFolderLastModifiedTime(AzureNativeFileSystemStore.java:2558)
      	at org.apache.hadoop.fs.azurenative.AzureNativeFileSystemStore.updateFolderLastModifiedTime(AzureNativeFileSystemStore.java:2569)
      	at org.apache.hadoop.fs.azurenative.NativeAzureFileSystem.updateParentFolderLastModifiedTime(NativeAzureFileSystem.java:2016)
      	at org.apache.hadoop.fs.azurenative.NativeAzureFileSystem.rename(NativeAzureFileSystem.java:1983)
      	at org.apache.hadoop.hbase.regionserver.wal.HLogSplitter$LogRecoveredEditsOutputSink$2.call(HLogSplitter.java:1161)
      	at org.apache.hadoop.hbase.regionserver.wal.HLogSplitter$LogRecoveredEditsOutputSink$2.call(HLogSplitter.java:1121)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      
      1. HADOOP-11523.1.patch
        2 kB
        Duo Xu
      2. HADOOP-11523.2.patch
        2 kB
        Duo Xu
      3. HADOOP-11523.3.patch
        2 kB
        Duo Xu
      4. HADOOP-11523.4.patch
        2 kB
        Duo Xu

        Issue Links

          Activity

          onpduo Duo Xu added a comment -

          Chris Nauroth

          Could you take a look?

          thomas.jungblut Thomas Jungblut added a comment -

          Good catch Duo. Thanks for fixing this.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12695335/HADOOP-11523.1.patch
          against trunk revision 89b0749.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          -1 release audit. The applied patch generated 1 release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-tools/hadoop-azure.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/5536//testReport/
          Release audit warnings: https://builds.apache.org/job/PreCommit-HADOOP-Build/5536//artifact/patchprocess/patchReleaseAuditProblems.txt
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5536//console

          This message is automatically generated.

          cnauroth Chris Nauroth added a comment -

          Hi Duo. Thank you for the patch.

          The current patch would acquire the lease for all rename operations, covering both block blobs and page blobs. During initial development of atomic rename, we were careful to limit the scope to only page blobs (typically used by HBase logs). Existing applications using block blobs might not be expecting the leases, so I think we need to make sure the lease acquisition only happens after checking AzureNativeFileSystemStore#isAtomicRenameKey.

          In the error handling, if an exception is thrown from the try block, and then another exception is also thrown from freeing the lease, then this would drop the original exception and throw the exception from freeing the lease. I suspect in general the main exception from the try block is going to be more interesting for root cause analysis, so I recommend throwing that one and just logging the one from freeing the lease, like so:

                  } finally {
                    try {
                      if (lease != null) {
                        lease.free();
                      }
                    } catch (Exception e) {
                      LOG.error("Unable to free lease on " + parentKey, e);
                    }
                  }
          

          In addition to the unit tests, I ran the test suite against a live Azure storage account and confirmed that everything passed.

          The release audit warning from Jenkins is unrelated to this patch.

          onpduo Duo Xu added a comment -

          Hi, Chris Nauroth

          Current HBase clusters in Azure, our configuration is

          "Name": "fs.azure.page.blob.dir", "Value": "\/hbase\/WALs,\/hbase\/oldWALs"
          

          In the exception above, WASB tried to update folder/blob "hbase/data/default/tdelrowtbl/3c842e8823c192d1028dc72ac3f22886/recovered.edits". This is apparently not a page blob. So lease acquisition is needed in block blob, at least for HBase.

          For the error handling, agree and I have attached a new patch.

          cnauroth Chris Nauroth added a comment -

          This is apparently not a page blob.

          Sorry, I mixed up 2 different concepts: page blobs and atomic rename. If a path is configured for atomic rename, that doesn't necessarily imply that it's a page blob.

          What is your setting for fs.azure.atomic.rename.dir? I suspect it covers the path that you mentioned. This is why I suggested a check on AzureNativeFileSystemStore#isAtomicRenameKey.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12695364/HADOOP-11523.2.patch
          against trunk revision ad55083.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          -1 release audit. The applied patch generated 1 release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-tools/hadoop-azure.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/5537//testReport/
          Release audit warnings: https://builds.apache.org/job/PreCommit-HADOOP-Build/5537//artifact/patchprocess/patchReleaseAuditProblems.txt
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5537//console

          This message is automatically generated.

          onpduo Duo Xu added a comment -

          Chris Nauroth

          I looked at AzureNativeFileSystemStore#isAtomicRenameKey, it will check if the key is in the set of atomicRenameDirs. And from AzureNativeFileSystemStore#initialize, I saw it will add hbase root dir into it.

                // Add to this the hbase root directory, or /hbase is that is not set.
                hbaseRoot = verifyAndConvertToStandardFormat(
                    sessionConfiguration.get("hbase.rootdir", "hbase"));
                atomicRenameDirs.add(hbaseRoot);
          

          This means all HBase folders are eligible for atomic rename, right? For fs.azure.atomic.rename.dir, in our PROD clusters, it is not set. So atomicRenameDirs only contains "/hbase".

          In this way, I am OK to add it, so that lease acquisition e will only apply to folders under /hbase.

          I have updated the patch.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12695371/HADOOP-11523.3.patch
          against trunk revision ad55083.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          -1 release audit. The applied patch generated 1 release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-tools/hadoop-azure.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/5538//testReport/
          Release audit warnings: https://builds.apache.org/job/PreCommit-HADOOP-Build/5538//artifact/patchprocess/patchReleaseAuditProblems.txt
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5538//console

          This message is automatically generated.

          cnauroth Chris Nauroth added a comment -

          Thanks, Duo Xu. I have just 2 more minor nitpicks. I suggest changing this:

                        LOG.error("Unable to free lease on " + parentKey);
          

          to this:

                        LOG.error("Unable to free lease on " + parentKey, e);
          

          This way, we'll log the full stack trace on lease free errors and have more information for troubleshooting.

          This is just a minor style point, but for the following, the keyword should be inline with the closing brace. Instead of this:

                    }
                    finally {
          

          We do this:

                    } finally {
          

          Instead of this:

                  }
                  else {
          

          We do this:

                  } else {
          
          onpduo Duo Xu added a comment -

          Chris Nauroth

          Thanks for pointing these out. I have updated the patch.

          cnauroth Chris Nauroth added a comment -

          +1 for patch v4 pending a fresh Jenkins run.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12695400/HADOOP-11523.4.patch
          against trunk revision e36ef3b.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          -1 release audit. The applied patch generated 1 release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-tools/hadoop-azure.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/5541//testReport/
          Release audit warnings: https://builds.apache.org/job/PreCommit-HADOOP-Build/5541//artifact/patchprocess/patchReleaseAuditProblems.txt
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/5541//console

          This message is automatically generated.

          cnauroth Chris Nauroth added a comment -

          I have committed this to trunk and branch-2. Duo, thank you for the contribution.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #6968 (See https://builds.apache.org/job/Hadoop-trunk-Commit/6968/)
          HADOOP-11523. StorageException complaining " no lease ID" when updating FolderLastModifiedTime in WASB. Contributed by Duo Xu. (cnauroth: rev f2c91098c400da6db0f5e8e49e9bf0e6444af531)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #89 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/89/)
          HADOOP-11523. StorageException complaining " no lease ID" when updating FolderLastModifiedTime in WASB. Contributed by Duo Xu. (cnauroth: rev f2c91098c400da6db0f5e8e49e9bf0e6444af531)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #823 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/823/)
          HADOOP-11523. StorageException complaining " no lease ID" when updating FolderLastModifiedTime in WASB. Contributed by Duo Xu. (cnauroth: rev f2c91098c400da6db0f5e8e49e9bf0e6444af531)

          • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2021 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2021/)
          HADOOP-11523. StorageException complaining " no lease ID" when updating FolderLastModifiedTime in WASB. Contributed by Duo Xu. (cnauroth: rev f2c91098c400da6db0f5e8e49e9bf0e6444af531)

          • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #86 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/86/)
          HADOOP-11523. StorageException complaining " no lease ID" when updating FolderLastModifiedTime in WASB. Contributed by Duo Xu. (cnauroth: rev f2c91098c400da6db0f5e8e49e9bf0e6444af531)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #90 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/90/)
          HADOOP-11523. StorageException complaining " no lease ID" when updating FolderLastModifiedTime in WASB. Contributed by Duo Xu. (cnauroth: rev f2c91098c400da6db0f5e8e49e9bf0e6444af531)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2040 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2040/)
          HADOOP-11523. StorageException complaining " no lease ID" when updating FolderLastModifiedTime in WASB. Contributed by Duo Xu. (cnauroth: rev f2c91098c400da6db0f5e8e49e9bf0e6444af531)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java

            People

            • Assignee:
              onpduo Duo Xu
              Reporter:
              onpduo Duo Xu
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development