Hadoop Common
  1. Hadoop Common
  2. HADOOP-10092

hadoop-2.2.0-src build fails owing to wrong maven-site-plugin version

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.2.0
    • Fix Version/s: None
    • Component/s: None
    • Target Version/s:
    • Release Note:
      Patches to update the maven-site-dependency to 3.3

      Description

      I downloaded hadoop-2.2.0-src.tar.gz , in an attempt to build the native libraries 64-bit, but building according to the instructions in BUILDING.txt with
      $ mvn package -Pdist,native,docs,src -DskipTests -Dtar
      fails because of this issue:
      https://cwiki.apache.org/confluence/display/MAVEN/AetherClassNotFound
      (ie. the build fails with:
      "java.lang.NoClassDefFoundError: org/sonatype/aether/graph/DependencyFilter
      Caused by: java.lang.ClassNotFoundException: org.sonatype.aether.graph.DependencyFilter
      "
      because the wrong version of maven-site-plugin is specified in the top level hadoop pom.xml, @ line 211 :
      <plugin>
      <artifactId>maven-site-plugin</artifactId>
      <version>3.0</version>
      ...
      Changing this to:
      <version>3.3</version>
      fixes the problem .

      1. HADOOP-10092.patch
        0.3 kB
        Daniele Demichelis

        Issue Links

          Activity

          Allen Wittenauer added a comment -

          Closing as a dupe

          Carlos Eduardo Moreira dos Santos added a comment -

          Works for me. Resolved a clean build issue in commit dc2caacfd04ed0af5df72bd2bc53668d44761737

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12623000/HADOOP-10092.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/3433//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/3433//console

          This message is automatically generated.

          Adam Berry added a comment -

          This isn't an issue for the Hadoop Development Tools, moved to Hadoop Common.


            People

            • Assignee:
              Unassigned
              Reporter:
              Jason Vas Dias
            • Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development