Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.10-incubating, 0.9.11-incubating
    • Fix Version/s: 0.9.12-incubating
    • Component/s: guacd
    • Labels:
      None
    • Environment:
      guacd connecting to Windows Server 2012

      Description

      Since guacd 0.9.10-incubating the mouse cursor shadow is a thick black shadow instead of transparent. Running guac as docker image.

      Broken cursor shadow:

      $ docker run --name guacd -p 4822:4822  -d glyptodon/guacd:0.9.10-incubating
      

      Correct cursor shadow:

      $ docker run --name guacd -p 4822:4822  -d glyptodon/guacd:0.9.9
      

      See attached screen shots.

      1. shadow-0.9.10.png
        3 kB
        Roman Stoffel
      2. shadow-0.9.9.png
        3 kB
        Roman Stoffel

        Issue Links

          Activity

          mike.jumper Michael Jumper added a comment -

          Confirmed independently of Docker - works on old 0.9.9 tag in git, but fails with master. Seems to be a regression related to the handling of cursor state vs. screen sharing. Somehow, the alpha channel is being munched.

          mike.jumper Michael Jumper added a comment -

          This is due to the switch to the internal common surface structure, which has historically supported only opaque images. The cursor used to be sent using raw Guacamole protocol, and thus the alpha channel was preserved, but switching over to the internal common surface implementation obliterated the alpha channel.

          Recent work on GUACAMOLE-168 via GUACAMOLE-188 added alpha support to the common surface, though, so this should be fixable with minimal changes.

          mike.jumper Michael Jumper added a comment -

          Fixed via GUACAMOLE-188.


            People

            • Assignee:
              mike.jumper Michael Jumper
              Reporter:
              Gamlor Roman Stoffel
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development