Uploaded image for project: 'Guacamole'
  1. Guacamole
  2. GUACAMOLE-1201

Audio Input issues - Recording at an incorrect rate and Having much noise

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.0, 1.1.0, 1.2.0
    • Fix Version/s: 1.4.0
    • Labels:
      None
    • Environment:
      FreeRDP 2.2.0, Apache Guacamole Server 1.3.0, Apache Guacamole Client 1.3.0
    • Flags:
      Important

      Description

      I found some audio input issues when using Audacity and Adobe Audition.

      The test environment follows as below:

      • FreeRDP: stable-2.0
      • Apache Guacamole Server: staging/1.3.0
      • Apache Guacamole Client: staging/1.3.0
      • Remote Server: Windows 10 64 bit Version 2004 (OS Build 19041.572)
      • Ubuntu 18.04 64 bit
      • Audacity 2.3.3
      • Adobe Audition 2020

       

      The test case follows as below:

      1. Connect to the remote server (Windows 10, 64bit) over the Apache Guacamole Client.
      2. In the remote server, run Audacity.
      3. In Audacity, click the record button and start to record the audio.
      4. In Audacity, after 10 seconds, click the stop button.
      5. In Audacity, click the play button.

       

      In step 5, we can see the following issues:

      1. The recording time is 10.5 seconds, but the actual recorded time is about 7.5 seconds. (see 'audacity-recorded-time.png' image.)
      2. The recorded audio has a lot of noise.

      FYI: When using Adobe Audition, the crash issue frequently occurs. (see 'adobe-audition-crash.png' image)

       

      The weird things follow as below:

      • When performing the above test case by using xfreerdp (2.2.0, c72055d74), we can't see the above two issues in Audacity.
      • When performing the above test case by using mstsc (10.0.18362), we can't see the above two issues in Audacity.

      Especially, when using the Apache Guacamole Server & Client, we can't see the above two issues in Microsoft Voice Recorder. (see 'ms-voice-recorder.png' image)

       

      For these audio input issues, I researched the followings:

       

      But I didn't get any solution and workaround.

       

      Please let me know some solution or workaround to fix these issues.

      Thanks.

        Attachments

        1. audacity-recorded-time.png
          20 kB
          Jimmy
        2. ms-voice-recorder.png
          144 kB
          Jimmy
        3. adobe-audition-crash-1.png
          50 kB
          Jimmy
        4. adobe-audition-crash-2.png
          118 kB
          Jimmy

          Issue Links

            Activity

              People

              • Assignee:
                mjumper Mike Jumper
                Reporter:
                MyJimmy Jimmy
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: