Flume
  1. Flume
  2. FLUME-1744

MemoryChannel transaction capacity higher than channel capacity contains no error message

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: v1.3.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Issue Links

        Activity

        Alexander Alten-Lorenz added a comment -

        Seems to be already fixed in trunk:

        2012-12-18 11:52:47,848 (conf-file-poller-0) [ERROR - org.apache.flume.node.PollingPropertiesFileConfigurationProvider$FileWatcherRunnable.run(PollingPropertiesFileConfigurationProvider.java:142)] Failed to load configuration data. Exception follows.
        java.lang.IllegalStateException: Transaction Capacity of Memory Channel cannot be higher than the capacity.

        Alexander Alten-Lorenz added a comment -

        Jepp, Brock has done this by solving FLUME-1571

        commit 5b4a63983af262417b58c2e2b956f0b34d1b7070
        Author: Brock Noland <brock@apache.org>
        Date: Tue Dec 11 14:10:15 2012 -0600

        FLUME-1571: Channels should check for positive capacity and transaction capacity values

        Diff:
        https://github.com/apache/flume/commit/5b4a63983af262417b58c2e2b956f0b34d1b7070#diff-7

        Brock, can you please mark this as solved (Duplicate of FLUME-1571)?

        Brock Noland added a comment -

        Yep, sorry about that Alex!


          People

          • Assignee:
            Alexander Alten-Lorenz
            Reporter:
            Brock Noland
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development