Flume
  1. Flume
  2. FLUME-1571

Channels should check for positive capacity and transaction capacity values

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: v1.4.0, v1.3.1
    • Component/s: None
    • Labels:
      None
    1. FLUME-1571.patch
      8 kB
      Hari Shreedharan
    2. FLUME-1571-2.patch
      8 kB
      Hari Shreedharan
    3. FLUME-1571-4.patch
      16 kB
      Hari Shreedharan

      Issue Links

        Activity

        Hari Shreedharan created issue -
        Hari Shreedharan made changes -
        Field Original Value New Value
        Attachment FLUME-1571.patch [ 12544875 ]
        Hari Shreedharan added a comment -

        Note that the patch was named incorrectly on RB

        Hari Shreedharan made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Assignee Hari Shreedharan [ hshreedharan ]
        Hari Shreedharan made changes -
        Attachment FLUME-1571-2.patch [ 12560245 ]
        Brock Noland added a comment -

        Hari,

        Could you link the RB item to this JIRA? Also I am seeing a ton of test failures:

        testBasicEncyrptionDecryption(org.apache.flume.channel.file.encryption.TestFileChannelEncryption): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testEncryptedChannelWithoutEncryptionConfigFails(org.apache.flume.channel.file.encryption.TestFileChannelEncryption): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testUnencyrptedAndEncryptedLogs(org.apache.flume.channel.file.encryption.TestFileChannelEncryption): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testBadKeyProviderInvalidValue(org.apache.flume.channel.file.encryption.TestFileChannelEncryption): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testBadKeyProviderInvalidClass(org.apache.flume.channel.file.encryption.TestFileChannelEncryption): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testBadCipherProviderInvalidValue(org.apache.flume.channel.file.encryption.TestFileChannelEncryption): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testBadCipherProviderInvalidClass(org.apache.flume.channel.file.encryption.TestFileChannelEncryption): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testBadKeyAlias(org.apache.flume.channel.file.encryption.TestFileChannelEncryption): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testFastReplay(org.apache.flume.channel.file.TestCheckpointRebuilder): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testCapacity(org.apache.flume.channel.file.TestFileChannel): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testRaceFoundInFLUME1432(org.apache.flume.channel.file.TestFileChannel): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testPutForceCheckpointCommitReplay(org.apache.flume.channel.file.TestFileChannel): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testPutCheckpointCommitCheckpointReplay(org.apache.flume.channel.file.TestFileChannel): File Channel transaction capacity cannot be greater than the capacity of the channel.
        testFileFormatV2postFLUME1432(org.apache.flume.channel.file.TestFileChannelFormatRegression): File Channel transaction capacity cannot be greater than the capacity o

        Brock

        Hari Shreedharan added a comment -

        Ah looks like I missed a bunch of git add in the tests. Sorry, will add it and submit new patch.

        Hari Shreedharan made changes -
        Remote Link This issue links to "Review (Web Link)" [ 11821 ]
        Hari Shreedharan made changes -
        Attachment FLUME-1571-4.patch [ 12560429 ]
        Brock Noland added a comment -

        Committed to trunk and 1.4!

        Brock Noland made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Fix Version/s v1.4.0 [ 12323372 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in flume-trunk #339 (See https://builds.apache.org/job/flume-trunk/339/)
        FLUME-1571: Channels should check for positive capacity and transaction capacity values (Revision 5b4a63983af262417b58c2e2b956f0b34d1b7070)

        Result = SUCCESS
        brock : http://git-wip-us.apache.org/repos/asf/flume/repo?p=flume.git&a=commit&h=5b4a63983af262417b58c2e2b956f0b34d1b7070
        Files :

        • flume-ng-channels/flume-file-channel/src/test/java/org/apache/flume/channel/file/TestFileChannelFormatRegression.java
        • flume-ng-channels/flume-file-channel/src/test/java/org/apache/flume/channel/file/TestFileChannelRestart.java
        • flume-ng-core/src/test/java/org/apache/flume/channel/TestMemoryChannel.java
        • flume-ng-channels/flume-file-channel/src/test/java/org/apache/flume/channel/file/encryption/TestFileChannelEncryption.java
        • flume-ng-core/src/main/java/org/apache/flume/channel/MemoryChannel.java
        • flume-ng-channels/flume-file-channel/src/main/java/org/apache/flume/channel/file/FileChannel.java
        • flume-ng-channels/flume-file-channel/src/test/java/org/apache/flume/channel/file/TestUtils.java
        • flume-ng-channels/flume-file-channel/src/test/java/org/apache/flume/channel/file/TestFileChannel.java
        • flume-ng-channels/flume-file-channel/src/test/java/org/apache/flume/channel/file/TestCheckpointRebuilder.java
        Brock Noland made changes -
        Link This issue is duplicated by FLUME-1744 [ FLUME-1744 ]
        Hari Shreedharan made changes -
        Fix Version/s v1.3.1 [ 12323879 ]
        Hari Shreedharan made changes -
        Issue Type Bug [ 1 ] Improvement [ 4 ]

          People

          • Assignee:
            Hari Shreedharan
            Reporter:
            Hari Shreedharan
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development