Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-6951

Incompatible versions of httpcomponents jars for Flink kinesis connector

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.3.4, 1.4.1, 1.5.0
    • Component/s: Kinesis Connector
    • Labels:
      None
    • Flags:
      Important

      Description

      In the following thread, Bowen reported incompatible versions of httpcomponents jars for Flink kinesis connector :

      http://search-hadoop.com/m/Flink/VkLeQN2m5EySpb1?subj=Re+Incompatible+Apache+Http+lib+in+Flink+kinesis+connector

      We should find a solution such that users don't have to change dependency version(s) themselves when building Flink kinesis connector.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                phoenixjiangnan Bowen Li
                Reporter:
                yuzhihong@gmail.com Ted Yu
              • Votes:
                1 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: