Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-6125

Commons httpclient is not shaded anymore in Flink 1.2

    Details

    • Type: Bug
    • Status: Open
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      This has been reported by a user: http://apache-flink-user-mailing-list-archive.2336050.n4.nabble.com/Return-of-Flink-shading-problems-in-1-2-0-td12257.html

      The Kinesis connector requires Flink to not expose any httpclient dependencies. Since Flink 1.2 it seems that we are exposing that dependency again

        Issue Links

          Activity

          Hide
          ralphsu Su Ralph added a comment -

          Cofirmed that on MAC, using maven 3.3.3 to build flink would have this package shade issue. Even with two mvn clean install (one in root, one in flink-dist).

          Show
          ralphsu Su Ralph added a comment - Cofirmed that on MAC, using maven 3.3.3 to build flink would have this package shade issue. Even with two mvn clean install (one in root, one in flink-dist).
          Hide
          rmetzger Robert Metzger added a comment -

          Quick update: I'm still planning to work on this, but there are too many things coming up right now.

          Show
          rmetzger Robert Metzger added a comment - Quick update: I'm still planning to work on this, but there are too many things coming up right now.
          Hide
          rmetzger Robert Metzger added a comment -

          I've unassigned myself. There are too many other things to work on

          Show
          rmetzger Robert Metzger added a comment - I've unassigned myself. There are too many other things to work on
          Hide
          phoenixjiangnan Bowen Li added a comment -
          Show
          phoenixjiangnan Bowen Li added a comment - This is similar to https://issues.apache.org/jira/browse/FLINK-6951
          Hide
          tzulitai Tzu-Li (Gordon) Tai added a comment -

          Bowen Li did you confirm whether or not this JIRA is still valid?

          AFAIK, what this JIRA explains is a bit different to what you bumped into in FLINK-6951.
          In FLINK-6951, what happened in your case is that you explicitly needed to add http dependencies to the lib folder due to hadoop-aws.

          Show
          tzulitai Tzu-Li (Gordon) Tai added a comment - Bowen Li did you confirm whether or not this JIRA is still valid? AFAIK, what this JIRA explains is a bit different to what you bumped into in FLINK-6951 . In FLINK-6951 , what happened in your case is that you explicitly needed to add http dependencies to the lib folder due to hadoop-aws.
          Hide
          phoenixjiangnan Bowen Li added a comment -

          Tzu-Li (Gordon) Tai I agree, I think this is different from FLINK-6951.

          Show
          phoenixjiangnan Bowen Li added a comment - Tzu-Li (Gordon) Tai I agree, I think this is different from FLINK-6951 .

            People

            • Assignee:
              Unassigned
              Reporter:
              rmetzger Robert Metzger
            • Votes:
              3 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:

                Development