Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-10070

Flink cannot be compiled with maven 3.0.x

    Details

      Description

      In FLINK-9986 we bumped the version of the git-commit-id-plugin to 2.1.14 which is incompatible with various maven versions, like 3.0.X.

      We can either bump the version to 2.2.4 to support all versions, or downgrade to 2.1.9 and rework FLINK-9986 with property exclusions.

      Additionally we should setup a test that checks the compatibility of Flink with various maven versions.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Zentol Chesnay Schepler
                Reporter:
                Zentol Chesnay Schepler
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: