Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Duplicate
    • Affects Version/s: 2.0.0-M10 (2.0.0.v20151221-M10)
    • Fix Version/s: 2.0.0-M11, 2.0.0-M12
    • Component/s: None
    • Labels:
    • Environment:
      Windows

      Description

      I am unable to save the configuration when I try to make any config changes

      I am using ApacheDS M21 (latest) and Directive Studio 2.0.0.v20151221-M10 (latest)

      Error:
      Unable to save configuration.

      • Changes could not be saved to the connection.
        java.lang.Exception: Changes could not be saved to the connection.
        at org.apache.directory.studio.apacheds.configuration.editor.ServerConfigurationEditorUtils.saveConfiguration(ServerConfigurationEditorUtils.java:370)
        at org.apache.directory.studio.apacheds.configuration.jobs.SaveConfigurationRunnable.run(SaveConfigurationRunnable.java:109)
        at org.apache.directory.studio.common.core.jobs.StudioJob.run(StudioJob.java:85)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

      Changes could not be saved to the connection.

      Studio Modification log:
      #!RESULT ERROR
      #!CONNECTION ldap://localhost:10389
      #!DATE 2016-01-15T05:47:23.141
      #!ERROR [LDAP: error code 16 - NO_SUCH_ATTRIBUTE: failed for MessageType : MODIFY_REQUEST Message ID : 109 Modify Request Object : 'ads-indexattributeid=apacheRdn,ou=indexes,ads-partitionid=example,ou=partitions,ads-directoryserviceid=default,ou=config' Modification[0] Operation : delete Modification ads-indexCacheSize: (null) Modification[1] Operation : delete Modification ads-indexCacheSize: (null) Modification[2] Operation : delete Modification ads-indexCacheSize: (null) Modification[3] Operation : delete Modification ads-indexCacheSize: (null) Modification[4] Operation : delete Modification ads-indexCacheSize: (null) Modification[5] Operation : delete Modification ads-indexCacheSize: (null) Modification[6] Operation : delete Modification ads-indexCacheSize: (null) Modification[7] Operation : delete Modification ads-indexCacheSize: (null) Modification[8] Operation : delete Modification ads-indexCacheSize: (null) Modification[9] Operation : delete Modification ads-indexCacheSize: (null) Modification[10] Operation : delete Modification ads-indexCacheSize: (null) Modification[11] Operation : delete Modification ads-indexCacheSize: (null) Modification[12] Operation : delete Modification ads-indexCacheSize: (null) Modification[13] Operation : delete Modification ads-indexCacheSize: (null) Modification[14] Operation : delete Modification ads-indexCacheSize: (null) Modification[15] Operation : delete Modification ads-indexCacheSize: (null) Modification[16] Operation : delete Modification ads-indexCacheSize: (null) Modification[17] Operation : delete Modification ads-indexCacheSize: (null) Modification[18] Operation : delete Modification ads-indexCacheSize: (null) Modification[19] Operation : delete Modification ads-indexCacheSize: (null) Modification[20] Operation : delete Modification ads-indexCacheSize: (null) Modification[21] Operation : delete Modification ads-systemPort: 10389 Modification[22] Operation : add Modification ads-systemPort: 10388 Modification[23] Operation : delete Modification ads-pwdAllowUserChange: (null) Modification[24] Operation : delete Modification ads-pwdMustChange: (null) Modification[25] Operation : delete Modification ads-pwdMinDelay: (null) Modification[26] Operation : delete Modification ads-pwdSafeModify: (null) Modification[27] Operation : delete Modification ads-pwdGraceExpire: (null) Modification[28] Operation : delete Modification ads-pwdMaxAge: (null) Modification[29] Operation : delete Modification ads-pwdMinAge: (null) Modification[30] Operation : delete Modification ads-pwdMaxLength: (null) Modification[31] Operation : delete Modification ads-pwdMaxIdle: (null) Modification[32] Operation : delete Modification ads-pwdMaxDelay: (null) Modification[33] Operation : delete Modification ads-jdbmPartitionOptimizerEnabled: (null) Modification[34] Operation : delete Modification ads-jdbmPartitionOptimizerEnabled: (null)org.apache.directory.api.ldap.model.message.ModifyRequestImpl@9114e4db: ERR_55 Trying to remove an non-existant attribute: attributetype ( 1.3.6.1.4.1.18060.0.4.1.2.164 NAME 'ads-indexCacheSize' DESC 'The number of key we store in the cache for this index' EQUALITY integerMatch ORDERING integerOrderingMatch SYNTAX 1.3.6.1.4.1.1466.115.121.1.27 SINGLE-VALUE USAGE userApplications )]
      dn: ads-indexAttributeId=apacheRdn,ou=indexes,ads-partitionId=example,ou=parti
      tions,ads-directoryServiceId=default,ou=config
      changetype: modify

        Issue Links

          Activity

          seelmann Stefan Seelmann added a comment -

          Duplicate of DIRSTUDIO-1080. This issues is already fixed, will be included in next Studio release.

          alexz Alex Zbarcea added a comment -

          using https://builds.apache.org/job/dir-studio/297/ the error is no longer reproducible.

          C27872 Allan Selvan added a comment -

          HI Alex,

          I cannot open the link.

          Regards,
          Allan Selvan

          C27872 Allan Selvan added a comment -

          This issue is not resolved for me yet and also I cannot find version M11 of the studio any where. Could you please help.

          elecharny Emmanuel Lecharny added a comment -

          Please don't reopen an issue which is a duplicate. The problem is solved, it's just that we haven't cut the release yet (that was what we worked on last week, but we had to defer it due to some issues).

          I'll push some installers soon so that you can play with them, but that will not be official installers. Check on DIRSTUDIO-1080 later on.

          elecharny Emmanuel Lecharny added a comment -

          Also note that there are nightly builds on https://builds.apache.org/job/dir-studio/. Please test them.

          C27872 Allan Selvan added a comment -

          Thanks

          C27872 Allan Selvan added a comment -

          Emmanuel Lecharny Thank you I already tried the nightly build and it worked perfectly. Sorry for reopening, I was not able to find the link to the nightly builds.


            People

            • Assignee:
              Unassigned
              Reporter:
              C27872 Allan Selvan
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development