Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M10 (2.0.0.v20151221-M10)
    • Fix Version/s: 2.0.0-M11, 2.0.0-M12
    • Labels:
      None
    • Environment:
      apacheds-2.0.0-M21-amd64 on Debian with Oracle Java;
      ApacheDirectoryStudio-2.0.0.v20151221-M10-win32.win32.x86_64.zip on Windows with Oracle Java

      Description

      We got error during saving partition preferences:

      Unable to save configuration.

      • Changes could not be saved to the connection.
        java.lang.Exception: Changes could not be saved to the connection.
        at org.apache.directory.studio.apacheds.configuration.editor.ServerConfigurationEditorUtils.saveConfiguration(ServerConfigurationEditorUtils.java:370)
        at org.apache.directory.studio.apacheds.configuration.jobs.SaveConfigurationRunnable.run(SaveConfigurationRunnable.java:109)
        at org.apache.directory.studio.common.core.jobs.StudioJob.run(StudioJob.java:85)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

      Changes could not be saved to the connection.

      Server instance wrapper log says:
      ERROR [org.apache.directory.server.core.schema.SchemaInterceptor] - ERR_55 Trying to remove an non-existant attribute: attributetype ( 1.3.6.1.4.1.18060.0.4.1.2.164 NAME 'ads-indexCacheSize'
      DESC 'The number of key we store in the cache for this index'
      EQUALITY integerMatch
      ORDERING integerOrderingMatch
      SYNTAX 1.3.6.1.4.1.1466.115.121.1.27
      SINGLE-VALUE
      USAGE userApplications )

        Issue Links

          Activity

          seelmann Stefan Seelmann added a comment -

          This issues is already fixed, will be included in next Studio release. Duplicate of DIRSTUDIO-1080


            People

            • Assignee:
              Unassigned
              Reporter:
              lbekk László Bekk
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development