Derby
  1. Derby
  2. DERBY-5670

multiple failures in AutoloadTest, in nightly regression test run

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Invalid
    • Affects Version/s: 10.9.1.0
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Issue & fix info:
      High Value Fix
    • Bug behavior facts:
      Regression Test Failure

      Description

      multiple errors and failures while running AutoloadTest in nightly run, linux, ibm16 against trunk.

      http://people.apache.org/~myrnavl/derby_test_results/main/linux/testlog/ibm16/1304157-suites.All_diff.txt

      It seems like something is going wrong with spawning, at least I have never seen a suites output file like this before. In this
      single suites output file there are 5 summary output files intermingled in the file, all the failures are from Autoload test. See
      link for complete file. I will highlight interesting pieces:

      There were 2 failures:
      1) spawnProcess:AutoloadTest(org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest)junit.framework.AssertionFailedError: Test process failed:Spawned org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest exitCode=1
      STDOUT:
      .........E.E.F....
      Time: 19.545
      There were 2 errors:
      1) testRegisteredDriver(org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest)java.sql.SQLException: No suitable driver
      at java.sql.DriverManager.getDriver(DriverManager.java:396)
      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest.testRegisteredDriver(AutoloadTest.java:337)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      2) testSuccessfulConnect(org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest)java.sql.SQLException: No suitable driver
      at java.sql.DriverManager.getConnection(DriverManager.java:330)
      at java.sql.DriverManager.getConnection(DriverManager.java:358)
      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest.testSuccessfulConnect(AutoloadTest.java:395)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      There was 1 failure:
      1) testUnsuccessfulConnect(org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest)junit.framework.ComparisonFailure: Unexpected SQL state. expected:<0800[4]> but was:<0800[1]>
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.assertSQLState(BaseJDBCTestCase.java:790)
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.assertSQLState(BaseJDBCTestCase.java:833)
      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest.testUnsuccessfulConnect(AutoloadTest.java:414)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      Caused by: java.sql.SQLException: No suitable driver
      at java.sql.DriverManager.getConnection(DriverManager.java:330)
      at java.sql.DriverManager.getConnection(DriverManager.java:358)
      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest.testUnsuccessfulConnect(AutoloadTest.java:409)
      ... 27 more

      FAILURES!!!
      Tests run: 15, Failures: 1, Errors: 2

      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest.spawnProcess(AutoloadTest.java:256)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:18)
      2) spawnProcess:JDBCDriversEmbeddedTest(org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest)junit.framework.AssertionFailedError: Test process failed:Spawned org.apache.derbyTesting.functionTests.tests.jdbcapi.JDBCDriversEmbeddedTest exitCode=1
      STDOUT:
      ........E.E.F....
      Time: 16.672
      There were 2 errors:
      1) testRegisteredDriver(org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest)java.sql.SQLException: No suitable driver
      at java.sql.DriverManager.getDriver(DriverManager.java:396)
      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest.testRegisteredDriver(AutoloadTest.java:337)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      2) testSuccessfulConnect(org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest)java.sql.SQLException: No suitable driver
      at java.sql.DriverManager.getConnection(DriverManager.java:330)
      at java.sql.DriverManager.getConnection(DriverManager.java:358)
      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest.testSuccessfulConnect(AutoloadTest.java:395)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      There was 1 failure:
      1) testUnsuccessfulConnect(org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest)junit.framework.ComparisonFailure: Unexpected SQL state. expected:<0800[4]> but was:<0800[1]>
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.assertSQLState(BaseJDBCTestCase.java:790)
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.assertSQLState(BaseJDBCTestCase.java:833)
      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest.testUnsuccessfulConnect(AutoloadTest.java:414)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      Caused by: java.sql.SQLException: No suitable driver
      at java.sql.DriverManager.getConnection(DriverManager.java:330)
      at java.sql.DriverManager.getConnection(DriverManager.java:358)
      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest.testUnsuccessfulConnect(AutoloadTest.java:409)
      ... 29 more

      FAILURES!!!
      Tests run: 14, Failures: 1, Errors: 2

      at org.apache.derbyTesting.functionTests.tests.jdbcapi.AutoloadTest.spawnProcess(AutoloadTest.java:256)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:113)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:18)

      FAILURES!!!
      Tests run: 15476, Failures: 2, Errors: 0

        Issue Links

          Activity

          Gavin made changes -
          Workflow jira [ 12659440 ] Default workflow, editable Closed status [ 12797136 ]
          Mike Matrigali made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Myrna van Lunteren added a comment -

          This has regressed in ibm 1.6 SR 11.

          Myrna van Lunteren made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Invalid [ 6 ]
          Myrna van Lunteren added a comment -

          Marking invalid as this was a JVM problem fixed in ibm 1.6 SR10.

          Myrna van Lunteren added a comment -

          Thanks for testing with the SR10.

          I do not think it was exactly the same issue as DERBY-4872, because adding derby.jar to the CLASSPATH in addition to derbyrun.jar got around that issue, and the scripts running suites.All export the CLASSPATH with derby.jar in it.

          Nonetheless, it's likely related, because I upgraded the ibm 1.6 version used in these tests to SR10 and it sure looks like this resolved this issue. There was no such failure today, whereas it was pretty consistent the last few days (compare http://people.apache.org/~myrnavl/derby_test_results/main/windows/testSummary-1306114.html or http://people.apache.org/~myrnavl/derby_test_results/main/linux/testSummary-1306101.html with http://people.apache.org/~myrnavl/derby_test_results/main/windows/testSummary-1305201.html or http://people.apache.org/~myrnavl/derby_test_results/main/linux/testSummary-1305191.html)

          Knut Anders Hatlen added a comment -

          FWIW, I'm not able to reproduce DERBY-4872 using SR10. I don't have a copy of SR9 to test with, but I suspect that this issue is the same as DERBY-4872 and that it has been fixed in the JVM between SR9 and SR10.

          Knut Anders Hatlen added a comment -

          I cannot tell from the test report what classpath the tests are running with, but is there any chance that they hit the JVM bug described in DERBY-4872?

          Knut Anders Hatlen added a comment -

          I just ran suites.All in my environment with ibm16 without seeing any failures, except the DST bug DERBY-3519. The JVM identified itself as

          java version "1.6.0"
          Java(TM) SE Runtime Environment (build pxi3260sr10-20111208_01(SR10))
          IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Linux x86-32 jvmxi3260sr10-20111207_96808 (JIT enabled, AOT enabled)
          J9VM - 20111207_096808
          JIT - r9_20111107_21307ifx1
          GC - 20110519_AA)
          JCL - 20111104_02

          The nightly tests appear to be using SR9, whereas I tested with SR10. Don't know if that matters.

          It would be interesting to know if AutoloadTest passes when run standalone on the machine where the failures are seen. That's essentially what the jdbcapi suite does right now; spawn a JVM that runs AutoloadTest standalone.

          Mike Matrigali added a comment -

          It seems likely these intermittent errors have been caused by changes recently checked in to nclude driver tests in jdbcapi suite

          Mike Matrigali made changes -
          Field Original Value New Value
          Link This issue is related to DERBY-5664 [ DERBY-5664 ]
          Mike Matrigali created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Mike Matrigali
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development