Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.9.1.0
    • Fix Version/s: 10.9.1.0
    • Component/s: Test
    • Labels:
      None
    • Environment:
      phoneME
    • Bug behavior facts:
      Regression Test Failure

      Description

      org.apache.derbyTesting.functionTests.tests.tools.ij3Test.ij3 (from org.apache.derbyTesting.functionTests.suites.All)
      junit.framework.ComparisonFailure: Output at line 1 expected:<ij[(CONNECTION1)]> --> but was:<ij[]> -->
      at org.apache.derbyTesting.functionTests.util.CanonTestCase.compareCanon(Unknown Source)
      at org.apache.derbyTesting.functionTests.util.ScriptTestCase.runTest(Unknown Source)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(Unknown Source)
      at junit.extensions.TestDecorator.basicRun(Unknown Source)
      at junit.extensions.TestSetup$1.protect(Unknown Source)
      at junit.extensions.TestSetup.run(Unknown Source)
      at junit.extensions.TestDecorator.basicRun(Unknown Source)
      at junit.extensions.TestSetup$1.protect(Unknown Source)
      at junit.extensions.TestSetup.run(Unknown Source)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(Unknown Source)
      at sun.misc.CVM.runMain(Unknown Source)

      1. d5346.diff
        1 kB
        Knut Anders Hatlen

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          1h 45m 1 Knut Anders Hatlen 20/Jul/11 11:25
          In Progress In Progress Closed Closed
          5m 19s 1 Knut Anders Hatlen 20/Jul/11 11:30
          Gavin made changes -
          Workflow jira [ 12621078 ] Default workflow, editable Closed status [ 12801176 ]
          Knut Anders Hatlen made changes -
          Status In Progress [ 3 ] Closed [ 6 ]
          Fix Version/s 10.9.0.0 [ 12316344 ]
          Resolution Fixed [ 1 ]
          Knut Anders Hatlen added a comment -

          Committed revision 1148687.

          Knut Anders Hatlen made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Knut Anders Hatlen made changes -
          Attachment d5346.diff [ 12487135 ]
          Knut Anders Hatlen added a comment -

          The attached patch sets ij.dataSource, ij.dataSource.databaseName and ij.dataSource.createDatabase in the test when running on JSR-169 platforms. This made the test pass both on Java 6 and on phoneME.

          Knut Anders Hatlen added a comment -

          When ij3 was converted to JUnit, the code that set ij.dataSource.databaseName and ij.dataSource.createDatabase was skipped because ij.dataSource wasn't set, and those two properties have no effect unless ij.dataSource is set. However, the instructions for running test suites in the old harness on CDC/Foundation say that the ij.dataSource property should be set explicitly on the command line, so the properties are in fact used on that platform. Setting those properties in the test made the test output the same on phoneME.

          Knut Anders Hatlen made changes -
          Assignee Knut Anders Hatlen [ knutanders ]
          Knut Anders Hatlen added a comment -

          The full diff between the expected and the actual output looks like this:

          1c1
          < ij(CONNECTION1)> –

          > ij> –
          24c24
          < ij(CONNECTION1)> – this test also exercises the shutdown on exit code

          > ij> – this test also exercises the shutdown on exit code

          Knut Anders Hatlen made changes -
          Field Original Value New Value
          Link This issue is broken by DERBY-5332 [ DERBY-5332 ]
          Knut Anders Hatlen added a comment -

          This test used to work on Foundation before it was converted to JUnit, so I don't think it should be excluded.

          Knut Anders Hatlen created issue -

            People

            • Assignee:
              Knut Anders Hatlen
              Reporter:
              Knut Anders Hatlen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development