Derby
  1. Derby
  2. DERBY-5078

Incorrect list of compatible JRE versions in client trace

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.8.1.2
    • Fix Version/s: 10.8.1.2
    • Component/s: Network Client
    • Labels:
      None

      Description

      When running with client side tracing enabled, these lines appear first in the trace file:

      [derby] BEGIN TRACE_DRIVER_CONFIGURATION
      [derby] Driver: Apache Derby Network Client JDBC Driver 10.8.0.0 alpha - (1075248P)
      [derby] Compatible JRE versions:

      { 1.3, 1.4 }

      The list of compatible JRE versions is wrong. The client driver doesn't work on 1.3, and 1.5 and 1.6 are missing from the list.

      1. versions.diff
        0.7 kB
        Knut Anders Hatlen

        Issue Links

          Activity

          Hide
          Knut Anders Hatlen added a comment -

          Committed revision 1075843.

          Show
          Knut Anders Hatlen added a comment - Committed revision 1075843.
          Hide
          Knut Anders Hatlen added a comment -

          The attached patch updates the list of compatible JRE versions to 1.4, 1.5 and 1.6.

          All the regression tests ran cleanly.

          Show
          Knut Anders Hatlen added a comment - The attached patch updates the list of compatible JRE versions to 1.4, 1.5 and 1.6. All the regression tests ran cleanly.

            People

            • Assignee:
              Knut Anders Hatlen
              Reporter:
              Knut Anders Hatlen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development