Derby
  1. Derby
  2. DERBY-4291

Intermittent failure in 'store/updatelocks.sql' on Windows Vista

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.5.3.0
    • Fix Version/s: 10.8.3.0, 10.9.1.0
    • Component/s: Test
    • Environment:
    • Urgency:
      Normal
    • Bug behavior facts:
      Regression Test Failure

      Description

          • Start: updatelocks jdk1.6.0_06 storemats:storemats 2009-06-24 23:16:00 ***
            23201 del
            < APP |UserTran|ROW |1 |X |A |(2,6) |GRANT|ACTIVE
            23201a23201
            > APP |UserTran|ROW |2 |X |A |(2,6) |GRANT|ACTIVE
            Test Failed.
          • End: updatelocks jdk1.6.0_06 storemats:storemats 2009-06-24 23:16:27 ***

      See http://dbtg.thresher.com/derby/test/Daily/jvm1.6/testing/testlog/vista/788063-derbyall_diff.txt

        Issue Links

          Activity

          Dag H. Wanvik added a comment -

          Instability also seen on Solaris:
          http://dbtg.foundry.sun.com/derby/test/Daily/jvm1.6/testing/testlog/sol/810585-derbyall_diff.txt
          although slightly different signature:

          > APP |UserTran|ROW |1 |U |A |(4,6) |GRANT|ACTIVE
          28579a28581
          > APP |UserTran|ROW |1 |U |A |(4,6) |GRANT|ACTIVE
          28586a28589
          > APP |UserTran|ROW |1 |U |A |(4,6) |GRANT|ACTIVE
          Test Failed.

          Mamta A. Satoor added a comment - - edited

          Saw following on trunk at revision 1069761 with Sun's jvm 1.6.0_18 on tinderbox http://dbtg.foundry.sun.com/derby/test/tinderbox_trunk16/jvm1.6/testing/testlog/SunOS-5.10_i86pc-i386/1069761-derbyall_diff.txt

              • Start: updatelocks jdk1.6.0_18 storemats:storemats 2011-02-11 14:11:23 ***
                2847,2856d2846
                < APP |UserTran|TABLE |1 |IX |A |Tablelock |GRANT|ACTIVE
                < ij> next scan_cursor;
                < A |B |C
                < --------------------------------------------------------------------------------------------------------------------------------------------------------
                < 3 |-30 |-three
                < ij> update a set b=30,c='three' where current of scan_cursor;
                < 1 row inserted/updated/deleted
                < ij> select * from lock_table order by tabname, type desc, mode, cnt, lockname;
                < USERNAME|TRANTYPE|TYPE |CNT |MODE|TABNAME |LOCKNAME |STATE|STATUS
                < ---------------------------------------------------------------------------
                2857a2848,2857
                > ij> next scan_cursor;
                > A |B |C
                > --------------------------------------------------------------------------------------------------------------------------------------------------------
                > 3 |-30 |-three
                > ij> update a set b=30,c='three' where current of scan_cursor;
                > 1 row inserted/updated/deleted
                > ij> select * from lock_table order by tabname, type desc, mode, cnt, lockname;
                > USERNAME|TRANTYPE|TYPE |CNT |MODE|TABNAME |LOCKNAME |STATE|STATUS
                > ---------------------------------------------------------------------------
                > APP |UserTran|TABLE |3 |IX |A |Tablelock |GRANT|ACTIVE
                2867 del
                < APP |UserTran|TABLE |2 |IX |A |Tablelock |GRANT|ACTIVE
                2867a2867
                > APP |UserTran|TABLE |3 |IX |A |Tablelock |GRANT|ACTIVE
                2874 del
                < APP |UserTran|TABLE |2 |IX |A |Tablelock |GRANT|ACTIVE
                2874a2874
                > APP |UserTran|TABLE |3 |IX |A |Tablelock |GRANT|ACTIVE
                14688,14697d14687
                < APP |UserTran|TABLE |1 |IX |A |Tablelock |GRANT|ACTIVE
                < ij> next scan_cursor;
                < A |B |C
                < --------------------------------------------------------------------------------------------------------------------------------------------------------
                < 3 |-30 |-three
                < ij> update a set b=30,c='three' where current of scan_cursor;
                < 1 row inserted/updated/deleted
                < ij> select * from lock_table order by tabname, type desc, mode, cnt, lockname;
                < USERNAME|TRANTYPE|TYPE |CNT |MODE|TABNAME |LOCKNAME |STATE|STATUS
                < ---------------------------------------------------------------------------
                14698a14689,14698
                > ij> next scan_cursor;
                > A |B |C
                > --------------------------------------------------------------------------------------------------------------------------------------------------------
                > 3 |-30 |-three
                > ij> update a set b=30,c='three' where current of scan_cursor;
                > 1 row inserted/updated/deleted
                > ij> select * from lock_table order by tabname, type desc, mode, cnt, lockname;
                > USERNAME|TRANTYPE|TYPE |CNT |MODE|TABNAME |LOCKNAME |STATE|STATUS
                > ---------------------------------------------------------------------------
                > APP |UserTran|TABLE |3 |IX |A |Tablelock |GRANT|ACTIVE
                14708 del
                < APP |UserTran|TABLE |2 |IX |A |Tablelock |GRANT|ACTIVE
                14708a14708
                > APP |UserTran|TABLE |3 |IX |A |Tablelock |GRANT|ACTIVE
                14716 del
                < APP |UserTran|TABLE |2 |IX |A |Tablelock |GRANT|ACTIVE
                14716a14716
                > APP |UserTran|TABLE |3 |IX |A |Tablelock |GRANT|ACTIVE
                Test Failed.
              • End: updatelocks jdk1.6.0_18 storemats:storemats 2011-02-11 14:11:35 ***
                ------------------------------------------------------
          Knut Anders Hatlen added a comment -

          Seen also when testing the 10.8.1.0 release candidate on Solaris 9:

                          • Diff file derbyall/encryptionAll/storemats/storemats/updatelocks.diff
              • Start: updatelocks jdk1.6.0_24 storemats:storemats 2011-04-05 13:40:19 ***
                5420a5421
                > APP |UserTran|ROW |1 |U |A |(4,6) |GRANT|ACTIVE
                5431a5433
                > APP |UserTran|ROW |1 |U |A |(4,6) |GRANT|ACTIVE
                5440a5443
                > APP |UserTran|ROW |1 |U |A |(4,6) |GRANT|ACTIVE
                Test Failed.
              • End: updatelocks jdk1.6.0_24 storemats:storemats 2011-04-05 13:40:45 ***

          http://dbtg.foundry.sun.com/derby/test/10.8.1.0_RC-1/logs/jvm1.6/solN-1/derbyall/report.txt

          Mike Matrigali added a comment -

          Failed in 10.8, windows, ibm142 run
          http://people.apache.org/~myrnavl/derby_test_results/v10_8/windows/testlog/ibm142/1242208-derbyall_diff.txt

          It looks like an unexpected committed deleted row, the test has just deleted and commited just prior to these
          locks being checked.

              • Start: updatelocks jdk1.4.2 storemats:storemats 2012-02-08 20:35:38 ***
                28561a28562
                > APP |UserTran|ROW |1 |U |A |(2,6) |GRANT|ACTIVE
                28570a28572
                > APP |UserTran|ROW |1 |U |A |(2,6) |GRANT|ACTIVE
                28579a28582
                > APP |UserTran|ROW |1 |U |A |(2,6) |GRANT|ACTIVE
                28586a28590
                > APP |UserTran|ROW |1 |U |A |(2,6) |GRANT|ACTIVE
                Test Failed.
              • End: updatelocks jdk1.4.2 storemats:storemats 2012-02-08 20:36:58 ***
          Mike Matrigali added a comment -

          Note that this test has been converted in trunk, so these errors should not happen in versions after 10.8. I ran trunk with
          Knut's patch in DERBY-1913 to sleep in the background daemon and did no see a failure in the updated test.

          Mike Matrigali added a comment -

          DERBY-5305, which converted this test to a new junit test and removed the existing updatelocks.sql has been implemented in trunk (10.9) and backported to 10.8. So should not see this issue again in 10.8 or future releases.

          Kathey Marsden added a comment -

          Reopen for 10.5 backport consideration. If working on the backport for this issue. Temporarily assign yourself and add a comment that you are working on it. When finished, reresolve with the new fix versions or label backport_reject_10_x as appropriate.

          Mike Matrigali added a comment -

          I don't think this one is worth backporting now. It is fixed with a newly converted test in 10.8. I suggest delaying backport until someone running
          old versions sees and complains about the error.

          Mamta A. Satoor added a comment -

          Failed on 10.7 codeline (1525194) on Windows machine with ibm1.5
          http://people.apache.org/~myrnavl/derby_test_results/v10_7/windows/testlog/ibm15/1525194-derbyall_diff.txt
          Diff file derbyall/encryptionAll/storemats/storemats/updatelocks.diff
          Start: updatelocks jdk1.5.0 storemats:storemats 2013-09-21 01:24:39 ***
          22688d22687
          < APP |UserTran|ROW |1 |X |A |(4,6) |GRANT|ACTIVE
          22690a22690
          > APP |UserTran|ROW |2 |X |A |(4,6) |GRANT|ACTIVE
          Test Failed.
          End: updatelocks jdk1.5.0 storemats:storemats 2013-09-21 01:24:53 ***
          ------------------------------------------------------


            People

            • Assignee:
              Mike Matrigali
              Reporter:
              Ole Solberg
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development