Derby
  1. Derby
  2. DERBY-4017

Removed deprecated jdk16 variable from the machinery which builds javadoc

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.5.1.1
    • Fix Version/s: 10.5.1.1
    • Component/s: Build tools
    • Labels:
      None

      Description

      The jdk16 variable is no longer needed for Derby compilation and has been deprecated as part of DERBY-3988. We no longer need the jdk14 variable for building javadoc either.

        Issue Links

          Activity

          Knut Anders Hatlen added a comment -

          Did you mean to say jdk16?

          Rick Hillegas added a comment - - edited

          Attaching derby-4017-01-aa-javadoc.diff. This patch removes the jdk16 variable from the javadoc targets.

          With this patch, I have successfully built the javadoc in the following environments. As always, it would be helpful if other people could test-drive this patch in their own environments:

          Mac OS X / Java 5 compiler
          Mac OS X / Java 6 compiler
          Ubuntu / IBM 5 compiler
          Ubuntu / IBM 6 compiler

          Touches the following file:

          M build.xml

          Rick Hillegas added a comment -

          Ayup.

          Rick Hillegas added a comment -

          Would appreciate it if someone else could test-drive these changes. Thanks.

          Myrna van Lunteren added a comment - - edited

          I applied the patch, then sync-ed up to current state and the patch appears ok to me...In fact, now seems necessary to get a correct javadoc when building with 1.5.

          I saw 1 extra warning when building with ibm 1.5:
          [javadoc] C:\derbyt\svn\trunk\java\client\org\apache\derby\jdbc\ClientBaseDataSource.java:1074: warning - Tag @see: reference not found: ClientConnectionPoolDataSource

          This warning doesn't show up when building with ibm1.6.

          (there's one other warning, [javadoc] C:\derbyt\svn\trunk\java\testing\org\apache\derbyTesting\functionTests\tests\jdbc4\ClobTest.java:333: warning - @param argument "parameterTypes" is not a parameter name. , but that's caused by commit r733725 by Kristian (no JIRA) and happens with both 1.5 and 1.6...)

          Rick Hillegas added a comment -

          Thanks, Myrna. I will take a look at the javadoc warning in a later patch. Committed at subversion revision 734711.

          Rick Hillegas added a comment -

          Cleaned up javadoc warnings at subversion revision 734756.


            People

            • Assignee:
              Rick Hillegas
              Reporter:
              Rick Hillegas
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development