Uploaded image for project: 'Derby'
  1. Derby
  2. DERBY-3833

OnlineCompressTest fails with ERROR XSDBB: Unknown page format at page Page(1,Container(0, 1440)) on 10.3 with ibm 1.5

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.3.3.1
    • Fix Version/s: None
    • Component/s: Store
    • Environment:
      10.3.3.1 build sync-ed up to revision 684621, ibm jvm 1.5
    • Urgency:
      Normal
    • Bug behavior facts:
      Data corruption, Regression Test Failure

      Description

      The test diff shows this error:
      88 del
      < Ending test: test7
      88 add
      > ERROR XSDBB: Unknown page format at page Page(1,Container(0, 1440)), page dump follows: Hex dump:
      > 00000000: 0000 0000 0000 0000 0000 0000 0000 0000 ................
      > 00000010: 0000 0000 0000 0000 0000 0000 0000 0000 ................
      ....(more)...

      This is the stack in derby.log:
      Checkpoint Daemon caught standard exception

      ------------ BEGIN ERROR STACK -------------

      ERROR XSDB3: Container information cannot change once written: was 0, now 80
      at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
      at org.apache.derby.impl.store.raw.data.AllocPage.WriteContainerInfo(Unknown Source)
      at org.apache.derby.impl.store.raw.data.FileContainer.writeHeader(Unknown Source)
      at org.apache.derby.impl.store.raw.data.RAFContainer.writeRAFHeader(Unknown Source)
      at org.apache.derby.impl.store.raw.data.RAFContainer.clean(Unknown Source)
      at org.apache.derby.impl.services.cache.CachedItem.clean(Unknown Source)

      I will shortly make a zip of the db and log etc. and attach.

      1. OnlineCompressTest.zip
        151 kB
        Myrna van Lunteren

        Issue Links

          Activity

          myrna Myrna van Lunteren added a comment -

          zipped up test dir (i.e. database, derby.log and properties files)

          mikem Mike Matrigali added a comment -

          Can you add the type of disk that test was run on (ide or scsi) and whether write cache was enabled or not?

          I just tried the test 200 times on a multi-processor, XP, ibm15 jvm, scsi disk, no write cache, sane classes and it passed every time. I am going to try insane tonight on this machine.

          kristwaa Kristian Waagan added a comment -

          Triaged July 3, 2009: Assigned normal urgency, marked as Data corruption.

          kristwaa Kristian Waagan added a comment -

          Added links to two related issues.
          Because of a fix committed as part of a related issue, it looks to me as if another attempt at reproducing the error should be made, and then close it if unable to reproduce.

          myrna Myrna van Lunteren added a comment -

          Closing as Cannot Reproduce because it's been a long time since I've seen this.
          If it occurs again, we should reopen.


            People

            • Assignee:
              Unassigned
              Reporter:
              myrna Myrna van Lunteren
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development