Uploaded image for project: 'Apache Cordova'
  1. Apache Cordova
  2. CB-12867

cordova-compat dependent version is not match between latest released plugins

    XMLWordPrintableJSON

    Details

      Description

      cordova-plugin-camera (2.3.1 and higher) is depending on cordova-plugin-compat@1.1.x. However, many other plugins (such as media, media-capture, geolocation, file, contacts) are depending on cordova-plugin-compat@1.0.x as of now. This is causing an issue that cordova-plugin-camera cannot be added to the project if the project already has one of cordova-plugin-compat@1.0.x dependent plugins and vise versa.
      It might be better to depend on the same version of cordova-plugin-compat for the next plugins release.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                yuukitada Yuuki Tada
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: