Details
-
Improvement
-
Status: Closed
-
Major
-
Resolution: Fixed
-
None
-
None
-
None
Description
Will clean up and refactor SQLSelect API:
Shorter style of chainable API :
1. rename 'useLocalCache' to 'localCache'
2. rename 'sharedCache' to 'sharedCache'
Misc:
3. useLocalCache is void. Must return SQLSelect<T>
4. 'cacheStrategy' should take cache groups vararg
5. 'cacheGroups' should have a collection variant