Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-11661

Cassandra 2.0 and later require Java 7u25 or later - jdk 101

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Urgent
    • Resolution: Fixed
    • Fix Version/s: 2.1.15, 2.2.7, 3.0.7, 3.7
    • Component/s: Legacy/Testing
    • Labels:
      None
    • Environment:

      Cassandra Server 2.1.5 and Java jdk1.7.0_101-b14

    • Severity:
      Critical

      Description

      We have been running the cassandr server version 2.1.5. Friday, we applied the latest java patch, Java(TM) SE Runtime Environment (build 1.7.0_101-b14). Cassandra cannot start with this patch. The cassandra log states: Cassandra 2.0 and later require Java 7u25 or later.

        Attachments

        1. 11661-2.1.patch
          0.8 kB
          Eduard Tudenhoefner
        2. 11661-2.2.patch
          0.8 kB
          Eduard Tudenhoefner
        3. 11661-3.0.patch
          0.8 kB
          Eduard Tudenhoefner

          Issue Links

            Activity

              People

              • Assignee:
                eduard.tudenhoefner Eduard Tudenhoefner
                Reporter:
                billysboutin William Boutin
                Authors:
                Eduard Tudenhoefner
                Reviewers:
                Michael Shuler
              • Votes:
                2 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: