Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.2.1
    • Component/s: build, ignite
    • Labels:
      None

      Description

      In BIGTOP-2097 some cleanups and improvements of the ignite packaging has been done. Unfortunately, now the service can not be started.

      1. the startup script is still called ignite-hadoop and as the result {[service ignite-hadoop-service start}} fails.
      2. the way the service script is generated, is toload a default file with the same name from /etc/default. However, right now default file is still at ignite-hadoop, but even if 1. above is fixed, it won't be able to load the faults and will fail.

      Alleged, the same will be happening on RPM side.

      Clearly, this mess needs to be fixed.

        Issue Links

          Activity

          cos Konstantin Boudnik added a comment -

          Thanks for the review, committed to the master!

          rvs Roman Shaposhnik added a comment -

          LGTM!

          cos Konstantin Boudnik added a comment -

          Turns out, renaming the service in the Puppet code broke the Debian deployment (duh!). So, I reverted that part back and instead made the CentOS service to be called ignite-hadoop-service everywhere.

          Now it works in both deployments. Phew...
          Ready to be committed.

          rvs Roman Shaposhnik added a comment -

          +1. LGTM!

          cos Konstantin Boudnik added a comment -

          Here's the patch. I will need to validate it on Debian, but Centos is now fixed and fully functional

          cos Konstantin Boudnik added a comment -

          It seems a part of the problem was caused by BIGTOP-2097 where the loop through the service was removed and a call to init.d.tmpl has been parametrised with a non-existing .svc definition. E.g. ignite.svc was used instead of ignite-hadoop.svc

          The second part of the problem was a genuin bug in the Ignite's url parsing code, so the hdfs URL has to contain a trailing slash. See the email exchange (no bug has been opened as of yet) here

          I will provide the patch shortly.

          cos Konstantin Boudnik added a comment -

          I am reopening this as start seeing the issues with ignite-hadoop service startup after upgrading to Ignite 1.9. There's the relevant part of the deployment log:

          Could not start Service[ignite-hadoop-service]: Execution of '/sbin/service ignite-hadoop-service start' returned 1: ignite-hadoop-service: unrecognized service
          Error: /Stage[main]/Ignite_hadoop::Deploy/Ignite_hadoop::Server[ignite-hadoop-node]/Service[ignite-hadoop-service]/ensure: change from stopped to running failed: Could not start Service[ignite-hadoop-service]: Execution of '/sbin/service ignite-hadoop-service start' returned 1: ignite-hadoop-service: unrecognized service
          
          cos Konstantin Boudnik added a comment -

          No signs of it. Closing

          cos Konstantin Boudnik added a comment -

          Hold on, I might have had a dirty build workspace. Validating...


            People

            • Assignee:
              cos Konstantin Boudnik
              Reporter:
              cos Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development