Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2061

toolchain is failing because add-apt-repository command isn't available off-hand

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.1.0
    • Component/s: toolchain
    • Labels:
      None

      Description

      Running gradle toolchain on our stock ubuntu-14.04 container gives

      Debug: Executing '/usr/bin/test -s /etc/apt/sources.list.d/http:--ppa_launchpad_net-openjdk-r-ppa-ubuntu-trusty.list'
      Error: Could not find command '/usr/bin/add-apt-repository'
      Error: /Stage[main]/Bigtop_toolchain::Jdk/Apt::Ppa[http://ppa.launchpad.net/openjdk-r/ppa/ubuntu]/Exec[add-apt-repository-http://ppa.launchpad.net/openjdk-r/ppa/ubuntu]/returns: change from notrun to 0 failed: Could not find command '/usr/bin/add-apt-repository'
      

        Issue Links

          Activity

          cos Konstantin Boudnik added a comment - - edited

          Possible caused by BIGTOP-1936

          oflebbe Olaf Flebbe added a comment -

          can use please check if

          gradlew puppet-modules toolchain

          works ?

          cos Konstantin Boudnik added a comment -

          Evidently, installing apt-get install software-properties-common on Ubuntu 14.04 addresses the issue. The matter gets complicated by the fact, that on Ubuntu 12.04 the package name was python-properties-common...

          cos Konstantin Boudnik added a comment -

          yes, it does. And BTW, seems that toolchain needs to dependsOn: toolchain-puppetmodules because of the apt module dependency.

          oflebbe Olaf Flebbe added a comment -

          This is already adressed by the ~/bigtop/bigtop_toolchain/bin/puppetize.sh script.

          oflebbe Olaf Flebbe added a comment -

          We do not support 12.04 any more

          oflebbe Olaf Flebbe added a comment -

          Konstantin Boudnik : The command is supposed to be run by docker/build-slaves/ubuntu-14.04/build.sh

          I will add documentation to the wiki if my spare time permits.

          cos Konstantin Boudnik added a comment -

          But toolchain is a user facing functionality and gradle toochain is what we officially recommend to be applied by our users. I am not clear about your comment.

          oflebbe Olaf Flebbe added a comment -

          Fixed by BIGTOP-2086


            People

            • Assignee:
              Unassigned
              Reporter:
              cos Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development