Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: build
    • Labels:
      None

      Description

      openjdk-7 on all platforms does not contain javafx. Hence 1.0 will be failing on OpenJDK build

      This specific report is from debian:

      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      [INFO]
      [INFO] ignite-tools ...................................... FAILURE [58.336s]
      [INFO] ignite-core ....................................... SKIPPED
      [INFO] ignite-log4j ...................................... SKIPPED
      [INFO] ignite-urideploy .................................. SKIPPED
      [INFO] ignite-spring ..................................... SKIPPED
      [INFO] ignite-hadoop ..................................... SKIPPED
      [INFO] ignite-extdata-p2p ................................ SKIPPED
      [INFO] ignite-extdata-uri ................................ SKIPPED
      [INFO] ignite-indexing ................................... SKIPPED
      [INFO] ignite-rest-http .................................. SKIPPED
      [INFO] ignite-clients .................................... SKIPPED
      [INFO] ignite-web ........................................ SKIPPED
      [INFO] ignite-aop ........................................ SKIPPED
      [INFO] ignite-ssh ........................................ SKIPPED
      [INFO] ignite-jta ........................................ SKIPPED
      [INFO] ignite-aws ........................................ SKIPPED
      [INFO] ignite-slf4j ...................................... SKIPPED
      [INFO] ignite-jcl ........................................ SKIPPED
      [INFO] ignite-schema-import .............................. SKIPPED
      [INFO] ignite-codegen .................................... SKIPPED
      [INFO] ignite-scalar ..................................... SKIPPED
      [INFO] ignite-visor-console .............................. SKIPPED
      [INFO] ignite-visor-plugins .............................. SKIPPED
      [INFO] ignite ............................................ SKIPPED
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 1:01.184s
      [INFO] Finished at: Thu Apr 16 12:05:16 CEST 2015
      [INFO] Final Memory: 33M/79M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal on project ignite-schema-import: Could not resolve dependencies for project org.apache.ignite:ignite-schema-import:jar:1.0.0: Could not find artifact javafx                   :jfxrt:jar:1.7.0_75 at specified path /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/jfxrt.jar -> [Help 1]
      [ERROR]
      
      1. BIGTOP-1833.patch
        3 kB
        Konstantin Boudnik
      2. BIGTOP-1833.patch
        1 kB
        Konstantin Boudnik

        Issue Links

          Activity

          jayunit100 jay vyas added a comment -

          I think Im pretty sure we are going to need openjdk8 for ignite, or oracle jdk 7.....

          Not sure how that effects other things.

          Ignite guys want to verify this?

          cos Konstantin Boudnik added a comment -

          Guys, I can not reproduce this issue with ignite-hadoop 1.0.0 and OpenJDK 1.7

          $ java -version
          java version "1.7.0_79"
          OpenJDK Runtime Environment (IcedTea 2.5.5) (7u79-2.5.5-0ubuntu0.14.04.2)
          OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)
          
          jayunit100 jay vyas added a comment - - edited

          sounds good. i bet it was just a 1.6 vs 1.7 issue iirc thats what i recall from talking to the ignite guys . vote to close

          cos Konstantin Boudnik added a comment -

          I have sent an email to Ignite dev@ list to confirm - hopefully we should be able to close this as nonrepro

          cos Konstantin Boudnik added a comment -

          Looks like the issue is real indeed and Ignite dev@ is working on it (see linked JIRA). Looks like there's a workaround for it though

          Now, I wonder why I am not hitting it in my build?

          oflebbe Olaf Flebbe added a comment -

          Workaround to install openjdk 8 is problematic at least for debian, since there is still no official release of openjdk8.

          Konstantin Boudnik: May I ask you whether bigtop should provide repositories, where suitable components for compiling can be downloaded from? That's ways better than the downloads in puppet bigtop_toolchain.

          I am thinking about providing the protoc compiler in the required version, gradle, scala, puppet components and backport of openjdk8 for debian.

          cos Konstantin Boudnik added a comment -

          We can do repository, of course. But why publicly available bits don't suffice in your opinion? Having our own repository will still require a mechanism to bring the bits down to the build host - so we'll have to use toolchain again (or a similar one). Am I missing anything?

          cos Konstantin Boudnik added a comment -

          Seems like IGNITE-791 has been fixed and will be released as a part of ignite-1.1 in the next a couple of days. We can wait for it and upgrade BOM (I think it make sense); or release as is with the workaround in mind. Thoughts?

          cos Konstantin Boudnik added a comment -

          Ok, I hit it too - so we are officially blocked The good news - Ignite community is working on 1.1 as we speak - hopefully will have a build soon.

          tomzeng Tom Zeng added a comment -

          I ran into the same, looks like Ignite 1.1 is not out yet, can we build again the latest RC?

          cos Konstantin Boudnik added a comment -

          rc7 is about to hit the incubator vote: they had to respin.

          cos Konstantin Boudnik added a comment -

          The possible patch. Hasn't been tested yet because Ignite 1.1.0 wasn't official released so far.

          cos Konstantin Boudnik added a comment -

          Working patch.

          cos Konstantin Boudnik added a comment -

          Ready for review.

          cos Konstantin Boudnik added a comment -

          Any one?

          evans_ye Evans Ye added a comment -

          I can do this. Just give me one or two hours.

          evans_ye Evans Ye added a comment -

          Tested on centos 6 and ubuntu 14.04. It's good!
          Committed and pushed.
          We finally have all the component ready for release. Thanks Konstantin Boudnik!


            People

            • Assignee:
              cos Konstantin Boudnik
              Reporter:
              oflebbe Olaf Flebbe
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development