Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: build
    • Labels:

      Description

      When I tried to build spark by gradle, I got the following error:

      error: cannot open /data/bigtop/output/spark/spark-1.0.1-1.el6.src.rpm: No such file or directory
      

      I have checked the output and found that bigtop wrote spark-core-1.0.1-1.el6.src.rpm to output dir

      [QUIET] [system.out] Wrote: /data/bigtop/build/spark/rpm/SRPMS/spark-core-1.0.1-1.el6.src.rpm
      

      The root cause is that packages.gradle uses spark as the name of rpm, but spark.spec uses spark-core

      1. BIGTOP-1462.patch
        7 kB
        Konstantin Boudnik

        Issue Links

          Activity

          cos Konstantin Boudnik added a comment -

          Thanks! The best way to link jiras together is to use More->Link menu instead of a plain comment.

          huLiu Hu Liu, added a comment -

          There is a regression caused by this fix , I created BIGTOP-1472 to track.

          rguo Guo Ruijing added a comment -

          BIGTOP-1466 was created to automate to include known issues in release notes.

          cos Konstantin Boudnik added a comment -

          Great plan! Let's work on it in 0.9.0 - I would very grateful for contributions!

          rguo Guo Ruijing added a comment -

          A special section on the Wiki explaining this known issue is difficult to manage release notes.
          We should automate release notes including known issue:

          1. Add keyword like "RELEASE_NOTES" in JIRA Label.

          2. Move JIRA description to comments and add Release Notes including issue and workaround in JIRA desription.

          3. search JIRAs (label == RELEASE_NOTES && Affect version == "Release version") and just put JIRA description to release notes.

          cos Konstantin Boudnik added a comment -

          Right, and it is an auto-generated file which should be a part of the voted source code for the release. However, if a fix isn't committed to the release I can not add its record to the release notes. You see my issue, right? I think we need to resort to a special section on the Wiki explaining this known issue.

          cos Konstantin Boudnik added a comment -

          Right, and it is an auto-generated file which should be a part of the voted source code for the release. However, if a fix isn't committed to the release I can not add its record to the release notes. You see my issue, right? I think we need to resort to a special section on the Wiki explaining this known issue.

          rguo Guo Ruijing added a comment -

          Release Notes is located in http://bigtop.apache.org/release-notes.html.
          We may add known issue with workaround in release-notes.

          cos Konstantin Boudnik added a comment -

          I don't think we have a concept of the release notes, but I like the idea, so let me see what I can do.

          rguo Guo Ruijing added a comment -

          you may add BIGTOP-1462 to release notes if you rule this ticket not to be a blocker for 0.8.0.

          cos Konstantin Boudnik added a comment -

          This bug should be blocker for bigtop 0.8 release since spark cannot be built.

          spark can be build with make (which is still the part of the build system), hence there's a viable workaround which doesn't block the release.

          As the release manager I rule this ticket not to be a blocker for 0.8.0

          rguo Guo Ruijing added a comment - - edited

          I understood bigtop branch 0.8 was already cut.

          This bug should be blocker for bigtop 0.8 release since spark cannot be built.

          1) spark cannot be built by gradle.

          2) make build is deprecated in https://issues.apache.org/jira/browse/BIGTOP-1314 in bigtop 0.8

          cos Konstantin Boudnik added a comment -

          I actually have already cut the release candidate and this bug isn't a blocker for release - hence, I have moved it to 0.9.0

          rguo Guo Ruijing added a comment -

          We should include this fix in bigtop 0.8 branch/release

          cos Konstantin Boudnik added a comment -

          Pushed to the master as 911f6e1

          rvs Roman Shaposhnik added a comment -

          +1

          cos Konstantin Boudnik added a comment -

          The mess was caused by mix-n-match use of package NAME and PACKAGE_NAME variables read from BOM file. Fixed for both dev and rpm build. Tested both builds - everything is working.

          cos Konstantin Boudnik added a comment -

          Looks like gradle build doesn't use PKG_NAME var correctly. In all cases but spark they were identical to the NAME, hence the bug has never been discovered. Good catch!


            People

            • Assignee:
              cos Konstantin Boudnik
              Reporter:
              huLiu Hu Liu,
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development