Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.8.0
    • Component/s: general
    • Labels:
      None

      Description

      Hbase needs to be bring up to 0.98. I'd suggest to go to 0.98.1 instead.

      1. BIGTOP-1281.patch
        3 kB
        Konstantin Boudnik
      2. BIGTOP-1281.patch
        3 kB
        Konstantin Boudnik
      3. BIGTOP-1281.patch
        1 kB
        Konstantin Boudnik

        Issue Links

          Activity

          Hide
          Konstantin Boudnik added a comment -

          Committed to master.

          Show
          Konstantin Boudnik added a comment - Committed to master.
          Hide
          Roman Shaposhnik added a comment -

          +1. LGTM.

          Show
          Roman Shaposhnik added a comment - +1. LGTM.
          Hide
          Konstantin Boudnik added a comment -

          thanks for the review Wenwu Peng.
          #0.98.2 has been done with new release in mind, because 0.98.1 has a bug in the some ant task deps resolution (see linked JIRAs). So, once the release is out - the patch should be good to go.

          1. good catch! I have it in my local workspace, but somehow I managed not to include it into the patch itself - uploading new fixed version.
          Show
          Konstantin Boudnik added a comment - thanks for the review Wenwu Peng . #0.98.2 has been done with new release in mind, because 0.98.1 has a bug in the some ant task deps resolution (see linked JIRAs). So, once the release is out - the patch should be good to go. good catch! I have it in my local workspace, but somehow I managed not to include it into the patch itself - uploading new fixed version.
          Hide
          Wenwu Peng added a comment -

          Apply patch did a little changed then Run command"make hbase-rpm" passed
          1. Change from 0.98.2 to 0.98.1 due 0.98.2 not out.
          2. Change HBASE_TARBALL_SRC to hbase-$(HBASE_BASE_VERSION)-src.tar.gz due to there is no hbase-version.tar.gz, if 0.98.2 have same structure, need to update the patch

          hbase-0.98.1-hadoop1-bin.tar.gz
          hbase-0.98.1-hadoop1-bin.tar.gz.mds
          hbase-0.98.1-hadoop2-bin.tar.gz
          hbase-0.98.1-hadoop2-bin.tar.gz.mds
          hbase-0.98.1-src.tar.gz
          hbase-0.98.1-src.tar.gz.mds

          Show
          Wenwu Peng added a comment - Apply patch did a little changed then Run command"make hbase-rpm" passed 1. Change from 0.98.2 to 0.98.1 due 0.98.2 not out. 2. Change HBASE_TARBALL_SRC to hbase-$(HBASE_BASE_VERSION)-src.tar.gz due to there is no hbase-version.tar.gz, if 0.98.2 have same structure, need to update the patch hbase-0.98.1-hadoop1-bin.tar.gz hbase-0.98.1-hadoop1-bin.tar.gz.mds hbase-0.98.1-hadoop2-bin.tar.gz hbase-0.98.1-hadoop2-bin.tar.gz.mds hbase-0.98.1-src.tar.gz hbase-0.98.1-src.tar.gz.mds
          Hide
          Konstantin Boudnik added a comment -

          Fully working version of the patch. Once 0.98.2 is out - we can roll.

          Show
          Konstantin Boudnik added a comment - Fully working version of the patch. Once 0.98.2 is out - we can roll.
          Hide
          Andrew Purtell added a comment -

          When releasing 0.96 and 0.98 (at least) we copy back site files from trunk on top of the branch site files after tagging the RC. Source tarballs released should build the site target successfully. Did you build from a branch checkout? Or does the site target fail if building from a release tarball? Would be good to know which.

          Show
          Andrew Purtell added a comment - When releasing 0.96 and 0.98 (at least) we copy back site files from trunk on top of the branch site files after tagging the RC. Source tarballs released should build the site target successfully. Did you build from a branch checkout? Or does the site target fail if building from a release tarball? Would be good to know which.
          Hide
          Konstantin Boudnik added a comment -

          We still need to do something about the broken dependency....

          Show
          Konstantin Boudnik added a comment - We still need to do something about the broken dependency....
          Hide
          Konstantin Boudnik added a comment -

          The build is broken for the Thrift module because of HBASE-10488

          Show
          Konstantin Boudnik added a comment - The build is broken for the Thrift module because of HBASE-10488

            People

            • Assignee:
              Konstantin Boudnik
              Reporter:
              Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development