HBase
  1. HBase
  2. HBASE-10488

'mvn site' is broken due to org.apache.jasper.JspC not found

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.99.0
    • Component/s: None
    • Labels:
      None

      Description

      From https://builds.apache.org/job/PreCommit-HBASE-Build/8642/artifact/trunk/patchprocess/patchSiteOutput.txt :

      [WARNING] The POM for org.apache.hbase:hbase-server:jar:0.99.0-20140127.165302-1 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
      [WARNING] The POM for org.apache.hbase:hbase-server:jar:tests:0.99.0-20140127.165302-1 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
      ...
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-site-plugin:3.3:site (default-site) on project hbase: failed to get report for org.apache.maven.plugins:maven-javadoc-plugin: Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.6:run (generate) on project hbase-thrift: An Ant BuildException has occured: taskdef class org.apache.jasper.JspC cannot be found
      
      1. 10488.patch
        1 kB
        Andrew Purtell

        Issue Links

          Activity

          stack added a comment -

          Ted Yu You fixing it? Otherwise lets close. This passes for me locally. You have other input?

          Ted Yu added a comment -

          QA build has shown 'mvn site' failure since #8633

          I can reproduce the failure locally.

          stack added a comment -

          I asked for other info and if filer was going to fix it. Got neither. Closing as invalid.

          stack added a comment -

          Resolving again. Was reopened but nothing filed to justify reopening.

          Andrew Purtell added a comment - - edited

          This comes from hbase-server and hbase-thrift modules, in the poms:

          <taskdef classname="org.apache.jasper.JspC" name="jspcompiler" classpathref="maven.compile.classpath"/>
          
          Andrew Purtell added a comment -

          Attached patch fixes the site target for me.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12629290/10488.patch
          against trunk revision .
          ATTACHMENT ID: 12629290

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop1.1. The patch compiles against the hadoop 1.1 profile.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          +1 site. The mvn site goal succeeds with this patch.

          +1 core tests. The patch passed unit tests in .

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8722//console

          This message is automatically generated.

          Andrew Purtell added a comment -

          +1 site. The mvn site goal succeeds with this patch.

          Will commit shortly.

          Andrew Purtell added a comment -

          Committed

          Hudson added a comment -

          FAILURE: Integrated in HBase-TRUNK-on-Hadoop-1.1 #92 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-1.1/92/)
          HBASE-10488 'mvn site' is broken due to org.apache.jasper.JspC not found (apurtell: rev 1568869)

          • /hbase/trunk/hbase-server/pom.xml
          • /hbase/trunk/hbase-thrift/pom.xml
          Hudson added a comment -

          FAILURE: Integrated in HBase-TRUNK #4925 (See https://builds.apache.org/job/HBase-TRUNK/4925/)
          HBASE-10488 'mvn site' is broken due to org.apache.jasper.JspC not found (apurtell: rev 1568869)

          • /hbase/trunk/hbase-server/pom.xml
          • /hbase/trunk/hbase-thrift/pom.xml
          stack added a comment -

          Good on you Andrew.

          Enis Soztutar added a comment -

          Andrew Purtell, it seems that bigtop needs this in 0.98 line as well. If you don't object, I'll commit it there as well.

          Ted Yu added a comment -

          I opened HBASE-11023 for backport.


            People

            • Assignee:
              Andrew Purtell
              Reporter:
              Ted Yu
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development