Uploaded image for project: 'Atlas'
  1. Atlas
  2. ATLAS-1822 Search Query Builder and Faceted Search in Atlas
  3. ATLAS-2025

Basic query with entity and tag filters : Providing invalid tag name for classification returns all entities matching typename/query

Attach filesAttach ScreenshotVotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 0.8.1, 1.0.0
    • Fix Version/s: 0.8.1, 1.0.0
    • Component/s: atlas-core
    • Labels:
      None

      Description

      Fired a basic query with following POST request body with Non Existing tag using curl (because UI only lets user select from existing tags):

      {
      "entityFilters":null,
      "tagFilters":null,
      "attributes":null,
      "query":null,
      "excludeDeletedEntities":true,
      "limit":25,
      "typeName":"kafka_topic",
      "classification":"non_existing_tag"
      }
      

      GET Basic search request with classification parameter also lists all the kakfa_topic entities:

      http://localhost:21000/api/atlas/v2/search/basic?typeName=kafka_topic&classification=non_existing_tag&limit=50
      

      Expected 40X Response code saying that tag doesn't exist. But the response listed all the kafka_topic entities. This gives an delusion that all returned kafka_topic entities are tagged with 'non_existing_tag'

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              apoorvnaik Apoorv Naik
              Reporter:
              sharmadhas Sharmadha S

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment