Accumulo
  1. Accumulo
  2. ACCUMULO-2646

Generate example configuration from template in build

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.1, 1.7.0
    • Component/s: build
    • Labels:
      None

      Description

      It was made clear in the mailing list discussion that there is value in providing static example configuration, for documentation purposes.

      As a follow-on to ACCUMULO-1395, it would be best if we generate this provided example configuration in the build, to save us the effort of maintaining separate version-controlled example files that are mostly redundant.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          80d 1h 39m 1 Christopher Tubbs 26/Jun/14 22:51
          In Progress In Progress Resolved Resolved
          1h 57m 1 Christopher Tubbs 27/Jun/14 00:49
          Resolved Resolved Reopened Reopened
          15h 15m 1 Christopher Tubbs 27/Jun/14 16:05
          Reopened Reopened Resolved Resolved
          1h 15m 1 Christopher Tubbs 27/Jun/14 17:20
          ASF subversion and git services made changes -
          Time Spent 50m [ 3000 ] 1h [ 3600 ]
          Worklog Id 16493 [ 16493 ]
          ASF subversion and git services logged work - 27/Jun/14 20:00
          ASF subversion and git services made changes -
          Time Spent 40m [ 2400 ] 50m [ 3000 ]
          Worklog Id 16491 [ 16491 ]
          ASF subversion and git services logged work - 27/Jun/14 20:00
          Bill Havanki made changes -
          Bill Havanki added a comment -

          Attaching diff for change on top of patch 0001 for detecting Darwin (Mac OS X) and using a BSD-specific getopt in bootstrap_config.sh. Tested on Mavericks.

          ASF subversion and git services made changes -
          Time Spent 0.5h [ 1800 ] 40m [ 2400 ]
          Worklog Id 16489 [ 16489 ]
          ASF subversion and git services logged work - 27/Jun/14 17:20
          ASF subversion and git services made changes -
          Time Spent 20m [ 1200 ] 0.5h [ 1800 ]
          Worklog Id 16488 [ 16488 ]
          ASF subversion and git services logged work - 27/Jun/14 17:20
          Christopher Tubbs made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Christopher Tubbs added a comment -

          It looks like the problem is that bootstrap_config.sh's command line arguments added in ACCUMULO-1395 uses GNU getopt, and that supports long opts, whereas BSD getopt does not. However, since the external script looks cleaner, I'm going to go ahead and apply that. A separate issue (ACCUMULO-2956) is opened to add non-GNU getopt support to bootstrap_config.sh

          Christopher Tubbs made changes -
          Christopher Tubbs added a comment -
          Christopher Tubbs made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Christopher Tubbs added a comment -

          As reported by Bill Havanki, this change does not work in OS X.

          The for loop to generate the config should be moved to a script.

          Christopher Tubbs made changes -
          Link This issue is related to ACCUMULO-2954 [ ACCUMULO-2954 ]
          Christopher Tubbs made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          ASF subversion and git services made changes -
          Time Spent 10m [ 600 ] 20m [ 1200 ]
          Worklog Id 16486 [ 16486 ]
          ASF subversion and git services logged work - 27/Jun/14 00:48
          • Time Spent:
            10m
             
            Commit 037ad964bb6313f78b80d4929450c6e2976c1a11 in accumulo's branch refs/heads/master from [~ctubbsii]
            [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=037ad96 ]

            ACCUMULO-2646 Generate config examples in assembly

              This patch removes unnecessary static configuration files, and instead
              replaces them with generated ones, to simplify improvements to example config
              files. This also gets some consistency in examples. The assembly component
              descriptor is cleaned up a bit by moving assembly-related files into the
              assemble module and by dropping some relative paths and vestigial file sets.
          ASF subversion and git services made changes -
          Remaining Estimate 0h [ 0 ]
          Time Spent 10m [ 600 ]
          Worklog Id 16485 [ 16485 ]
          ASF subversion and git services logged work - 27/Jun/14 00:47
          • Time Spent:
            10m
             
            Commit 037ad964bb6313f78b80d4929450c6e2976c1a11 in accumulo's branch refs/heads/1.6.1-SNAPSHOT from [~ctubbsii]
            [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=037ad96 ]

            ACCUMULO-2646 Generate config examples in assembly

              This patch removes unnecessary static configuration files, and instead
              replaces them with generated ones, to simplify improvements to example config
              files. This also gets some consistency in examples. The assembly component
              descriptor is cleaned up a bit by moving assembly-related files into the
              assemble module and by dropping some relative paths and vestigial file sets.
          Christopher Tubbs made changes -
          Fix Version/s 1.6.1 [ 12325441 ]
          Christopher Tubbs made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Christopher Tubbs made changes -
          Link This issue is related to ACCUMULO-2944 [ ACCUMULO-2944 ]
          Josh Elser made changes -
          Link This issue is required by ACCUMULO-2926 [ ACCUMULO-2926 ]
          Christopher Tubbs made changes -
          Description It was made clear [http://mail-archives.apache.org/mod_mbox/accumulo-dev/201404.mbox/%3CCAFAMeYKwDsAmWSevoUWWAC5EAomUHeQ_3Skt8hF5o7ydG8iNMA@mail.gmail.com%3E|in the mailing list discussion] that there is value in providing static example configuration, for documentation purposes.

          As a follow-on to ACCUMULO-1395, it would be best if we generate this provided example configuration in the build, to save us the effort of maintaining separate version-controlled example files that are mostly redundant.
          It was made clear [in the mailing list discussion|http://mail-archives.apache.org/mod_mbox/accumulo-dev/201404.mbox/%3CCAFAMeYKwDsAmWSevoUWWAC5EAomUHeQ_3Skt8hF5o7ydG8iNMA@mail.gmail.com%3E] that there is value in providing static example configuration, for documentation purposes.

          As a follow-on to ACCUMULO-1395, it would be best if we generate this provided example configuration in the build, to save us the effort of maintaining separate version-controlled example files that are mostly redundant.
          Christopher Tubbs made changes -
          Field Original Value New Value
          Link This issue depends upon ACCUMULO-1395 [ ACCUMULO-1395 ]
          Christopher Tubbs created issue -

            People

            • Assignee:
              Christopher Tubbs
              Reporter:
              Christopher Tubbs
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 1h
                1h

                  Development