Issue 42730 - Installation needs to auto-config OOo appropriately for an environment's current locale
Installation needs to auto-config OOo appropriately for an environment's curr...
Status: CLOSED FIXED
Product: General
Classification: Code
Component: code
680m79
All All
: P3 trivial with 2 votes (vote)
: OOo 2.0.1
Assigned To: helge.delfs
issues@framework
http://specs.openoffice.org/g11n/lang...
: oooqa
: 48123 (view as issue list)
Depends on: 32939 48117 48123
Blocks: 41707
  Show dependency treegraph
 
Reported: 2005-02-14 13:06 UTC by samphan
Modified: 2005-11-18 13:27 UTC (History)
8 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Spec draft (71.80 KB, application/vnd.sun.xml.writer)
2005-09-20 05:11 UTC, falko.tesch
no flags Details
Spec update! (71.93 KB, application/vnd.sun.xml.writer)
2005-09-21 09:40 UTC, falko.tesch
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description samphan 2005-02-14 13:06:00 UTC
The goal is to make Thai (and other language) users to be able to use the OOo
binary in their language out-of-the-box. So there'll be no need for Thai (or
other language) specific versions of OOo. To accomplish this, the setup program
should consider the user's system locale and configure the installation
accordingly. An example of the configurations (when the system locale is Thai)
are :-

Tools/Options/Language Settings
	Languages
		Locale setting : Thai
		CTL : Thai
	Complex Text Layout
		Use sequence checking: enable
The setup program should also set the default font for CTL appropriately for the
user's platform.
Comment 1 arthit 2005-02-15 18:33:23 UTC
art -> samphan:
To make it more general,
could you please change the summary to

"On machine with X locale, installation needs to be set up appropriately for
that locale"

or something similar. Thanks.
Comment 2 arthit 2005-02-21 05:23:04 UTC
Component -> "Installatoin".
Confirmed.
Comment 3 arthit 2005-02-21 05:23:35 UTC
Additional configurations that could be set at the installation time:

Tools: Options:
- OOo: User Data: Country  (if it's a country-specific locale, e.g. en_GB)
- Load/Save: HTML Compat.: Character set
- Language Settings: (all)
- Writer: General: Measurement unit
- Writer: View: Horizontal/Vertical ruler
- Writer: Basic Fonts (all)
- Writer/Web: View: Horizontal/Vertical ruler
- Writer/Web: View: Measurement unit
- Calc: General: Measurement unit
- Calc: Calculate: Date
- Impress: General: Unit of measurement
- Draw: General: Unit of measurement


Format: Page:
- Page Style: Page: Page format: Format (e.g. A4, Letter, ..)
- Page Style: Page: Page format: Text direction (left-to-right, right-to-left
(horizonal/vertical))


Others..
- default dictionary for spell checker
- default thesaurus
- other language resources
- default bullet/numbering style
Comment 4 arthit 2005-02-21 06:30:56 UTC
related issue,
issue 3729 : Easier/automatic setting of default paper size and measurement units
Comment 5 arthit 2005-02-21 07:17:54 UTC
related issue,
issue 39733 : Support default value for measurement units,paper size,date/number
format settings
Comment 6 Olaf Felka 2005-02-21 08:55:49 UTC
of: This doesn't make sense at installation time. One setting for all user? No
matter which locale I have. That's not 'installation'.
Comment 7 arthit 2005-02-21 11:58:36 UTC
I think it should read as "One _default_ setting for every new user",
user can change any setting later at his/her will.

The thing this feature will do is trying to _minimize_ the changes that a user
have to do by him/herself. By guessing a logical default setting from user's locale.

I think at least, at the installation time, the program do ask for "Country",
that's enough to reasonaly guess many things like:
currency, measurement units, paper size, date format, and, in some case, language.
Comment 8 aparan 2005-02-24 06:28:32 UTC
IMHO some sort of pattern should be buiilt into the installation sets, depending
upon the localisation.  So that there would not be any need to ask the user for
this setting and that, but by default OOo should follow the default settings as
per the localisation.  If an user wants to customise the settings, it is fine. 
These changes could be taken only as user-specific and not general.

As far as the installation sets are locale-specific and not general for OOo
there would not be any need to ask for the 'Country'.
Comment 9 jjc 2005-04-11 07:27:39 UTC
OOo seems to (very) partially do this already.  With m87 on Windows XP SP2, if I
install on a machine with a US locale, CTL is not enabled.  However, if I
install on a machine with all regional and language options set to Thai -- both
"Regional Options" | "Standards and Formats" to Thai, "Supplemental language
support" to include complex script support and the Advanced|"Language for
non-Unicode programs" (i.e. system locale) to Thai -- then OOo automatically
enabled CTL support, although it doesn't set the default CTL language to Thai. 
Comment 10 jjc 2005-04-25 12:32:28 UTC
On Windows there are two independent locales:

- the user locale (in XP, set on the "Regional Options" tab of "Regional and
Language Settings"); this is per-user

- the system locale (in XP, set in the "Language for non-Unicode programs" box
on the "Advanced" tab of "Regional and Language Settings"); this is system wide
not per-user

The other relevant bit of data on the system is which  of the 17 language groups
have been installed. There's an API to check this (IsValidLanguageGroup). This
is controlled by the "Supplemental language support" box on the "Languages" tab
of "Regional and Language Settings".  XP combines the language groups into 3
language collections: basic, east asian, and complex script.

OOo currently appears to use the user locale to determine whether to enable the
CTL support.  Unfortunately this doesn't work very well, because it's very
common for machines in Thailand for the user locale to be US (at least from my
not very representative survey).

Thai users are often quite happy running with a US user locale: it doesn't
bother them enough that they want to change it.  However, all users who want to
type Thai will have the Thai language group installed.  They will also almost
always have Thai as their system locale: the main reason for this is that
there's an undocumented Windows feature that making Thai the system locale
enables the use of grave accent to switch input languages; this was the default
behaviour of Thai Windows 95/98/Me, and is generally much preferred to
Alt/Ctrl+Shift.

I would suggest enabling CTL support if any complex script language groups are
installed.

For the default CTL languages, I would suggest trying first the user locale and
then the system locale and using whichever is a complex script language.
Comment 11 jjc 2005-04-25 14:27:33 UTC
I'm going to try to split this up into individual issues: it's a bit too vague
to be implemented as is.
Comment 12 jjc 2005-04-25 14:30:04 UTC
I'm going to try to split this up into individual issues: it's a bit too vague
to be implemented as is.
Comment 13 Martin Hollmichel 2005-05-11 16:31:45 UTC
set target to 2.0.1
Comment 14 falko.tesch 2005-09-20 05:05:39 UTC
*** Issue 48123 has been marked as a duplicate of this issue. ***
Comment 15 falko.tesch 2005-09-20 05:08:25 UTC
FT: A specification draft has been attached. This draft also covers 48123 which
I have closed as duplicate to this one therefore.
Note: I will publish the specification on OO.org as soon as I have access back
to CVS.
Comment 16 falko.tesch 2005-09-20 05:11:10 UTC
Created attachment 29698 [details]
Spec draft
Comment 17 falko.tesch 2005-09-21 09:40:42 UTC
Created attachment 29748 [details]
Spec update!
Comment 18 falko.tesch 2005-09-26 14:52:48 UTC
FT: Specification is now checked into CVS and available through _see URL in
URL-field of this issue_. Please disregard the attached early draft from now on.
Thanks.
Comment 19 Oliver Specht 2005-10-27 10:22:35 UTC
Fixed in cws thaiissues in 
desktop/source/app/langselect.cxx
svtools/inc/languageoptions.hxx
svtools/source/config/cjkoptions.cxx
svtools/source/config/ctloptions.cxx
svtools/source/config/languageoptions.cxx
Comment 20 Oliver Specht 2005-10-31 11:19:34 UTC
Reassigned for verification

re-open issue and reassign to sba@openoffice.org
Comment 21 Oliver Specht 2005-10-31 11:19:46 UTC
reassign to sba@openoffice.org
Comment 22 Oliver Specht 2005-10-31 11:19:57 UTC
reset resolution to FIXED
Comment 23 ulf.stroehler 2005-10-31 17:20:22 UTC
QA considers (parts of) this issue duplicate.
Automatically setting the default document locale depending on the desktop
locale is already subject of issue 32939/cws 'lo8' and integrated in m136.
Hence QA insists on a resync to m136 to anticipate eventual probs.
Comment 24 stefan.baltzer 2005-10-31 18:04:13 UTC
SBA->HDE: Please take over.

re-open issue and reassign to hde@openoffice.org
Comment 25 stefan.baltzer 2005-10-31 18:04:34 UTC
reassign to hde@openoffice.org
Comment 26 stefan.baltzer 2005-10-31 18:17:17 UTC
reassign to hde@openoffice.org
Comment 27 thorsten.ziehm 2005-11-01 09:37:17 UTC
set back to 'resolved/fixed'
Comment 28 helge.delfs 2005-11-04 07:25:05 UTC
.
Comment 29 helge.delfs 2005-11-04 07:26:16 UTC
.
Comment 30 helge.delfs 2005-11-04 07:28:37 UTC
HDE->OS: if system locale is set to 'Thai' the CTL language in office is set to
'none' and not to 'Thai' as expected
Comment 31 Oliver Specht 2005-11-09 12:16:32 UTC
The language setting is done but it's not active at the first start. 
Closing the office and restarting it make the setting active.

Start the office on either Linux or Windows (Solaris not tested) with a CTL
locale set. When the wizard starts the Linguistic.xcu contains the related CTL
language as DefaultLocale_CTL property. The language setting in
tools/options/language settings/languages shows no selection for CTL. 
Comment 32 Stephan Bergmann 2005-11-09 13:50:10 UTC
sb->os:  "The language setting is done but it's not active at the first start."
is fixed now (desktop/source/app/langselect.cxx 1.16.40.4).
Comment 33 Oliver Specht 2005-11-10 07:14:36 UTC
Reassigned for verification
Comment 34 Oliver Specht 2005-11-10 07:15:44 UTC
.
Comment 35 helge.delfs 2005-11-10 08:53:40 UTC
HDE: OK in CWS
Comment 36 helge.delfs 2005-11-18 13:27:23 UTC
HDE: OK in SRC680m141