Issue 25945 - Allow disabling of tooltip on mousewheel scroll
Allow disabling of tooltip on mousewheel scroll
Status: RESOLVED FIXED
Product: Writer
Classification: Application
Component: ui
OOo 1.1.1
All All
: P3 trivial with 54 votes (vote)
: 4.0.0
Assigned To: Ariel Constenla-Haile
issues@sw
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-27 14:36 UTC by edoloughlin
Modified: 2012-12-11 15:29 UTC (History)
13 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Writer document with macros to toggle these settings (18.63 KB, application/vnd.oasis.opendocument.text)
2012-07-18 05:39 UTC, Ariel Constenla-Haile
no flags Details
Screen shot showing the misplaced tool tip (167.82 KB, image/png)
2012-07-19 20:30 UTC, rgb
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description edoloughlin 2004-02-27 14:36:51 UTC
I find the scrollbar tooltip (when scrolling with mouse wheel)to be quite
annoyong. As it obstructs the view of the text underneath (and it flickers, see
21754).

The only way to disable it is to disable all tooltips, which I don't want to do.
It would be good if it could be disabled independently.
Comment 1 jack.warchold 2004-03-01 12:05:54 UTC
changed summery to :enable disabling of tooltips for each menue or toolbar 
independently

reassigned to bh
Comment 2 kengrace 2007-12-31 18:15:51 UTC
A number of threads in the forum deprecate the document details tooltip. Users 
have a choice between a substantial tip box when they touch the scroll wheel, 
or no use of the tooltip to indicate the purpose of buttons. Splitting the 
options for program and document tooltips would improve the inteface.
Comment 3 icebike 2008-10-24 22:49:33 UTC
This request has been here since the Pleistoscene, I can't believe after 
waiting patiently for version 3 that this problem still persists. 

This was originally a request to suppress tips showing location while 
scrolling.  By changing the definition, JW has totally perverted the request 
and lumped it in with far less annoying and seldom wanted features.

Who exactly needs this information to pop up?  Its in the status bar.
This just slows down the interface and makes it really annoying to scroll the 
document.

It doesn't make sense to hold this item until there is the ability to 
separately disable tool tips on a Per Menu basis, because this is not a menu.  
Let me put it more bluntly: THIS IS NOT A MENU.

There is little need to turn off tool tips in menus, because if a user knows 
what a button does, they click it and go, and the tip never shows. The 
proficient user probably NEVER sees a menu tool tip.  But no one can avoid 
this scroll bar.

Please consider separating this from a mor general (and useless) per-tool bar 
tip selection and put it as a separate stand alone bug report. It is the 
single most annoying aspect of document management in OOO writer.


Comment 4 nicminus 2009-02-20 01:27:48 UTC
*** Issue 25945 has been confirmed by votes. ***
Comment 5 nicminus 2009-02-20 01:30:36 UTC
I agree with icebike - I don't necessarily need to turn off each tooltip
independently, but the tooltip that is displayed whilst scrolling seems
particularly useless and annoying.

I scroll a lot in large documents. This minor inconvenience is cumulatively
extremely annoying and distracting. Does the tooltip ever need to be displayed
at all? 
Comment 6 edoloughlin 2009-02-20 17:10:53 UTC
Fixed summary to reflect original intention as also noted by other comments.
Comment 7 ma2412ma 2009-05-29 11:38:24 UTC
I absolutely agree. Please implement an option to turn off only the scroll
tooltip! It annoys the hell out of me.
Comment 8 luke_nz 2009-06-22 03:32:28 UTC
Feel strongly that showing the tooltip with location on scroll is pointless and
annoying, should be removed outright (not made optional).  Found this via google
search and forum posting.  Please fix!
Comment 9 lacos 2009-07-01 13:06:52 UTC
Until this is fixed, you might find this workaround useful (which is fully
described in the help): just turn off all tips, and whenever you need tips for
icons, just press Shift+F1, which enters extended tips mode temporarily. Then
hover over icons, click desired one, or bail out with ESC.
Comment 10 bitkeeper 2010-01-07 16:07:54 UTC
For God's sake, please, remove this tooltip for good!
Do not make it optional. It is not a feature, but useless and annoying nuisance.
Comment 11 elvenic 2010-02-19 18:40:58 UTC
I agree with bitkeeper. This tooltip should not exist at all. Information about
current page number is already displayed on the status bar. 
Comment 12 marinespl 2010-03-05 23:09:17 UTC
will it be ever at least touched? 6 years is too short for commenting no more 
than few lines of code?
Comment 13 tarverator 2010-03-23 22:24:13 UTC
I found this annoying enough to stop what I was doing, Google it, find this
Issue, register on this site, and vote.  Now, PLEASE get rid of this nuisance!
Comment 14 captainflint 2010-04-21 13:34:09 UTC
Plus my vote for removing this darn tooltip. I cannot understand how it's 
possible to work with it at all...
Comment 15 randomquest 2010-04-24 10:47:57 UTC
I copletely agree with everyone above: this thing is *extremely* annoying, and the fact I can't 
deal with this really drives me mad. Please, do something with this. I believe it would take a 
few lines to code over there.
Comment 16 bettina.haberer 2010-05-21 14:58:41 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements". 
Comment 17 greyeagle 2010-07-07 06:50:09 UTC
This tip while working on a text is extremely annoying while else the tips are
very useful. So please either eliminate this hovering annoyance or make it
switchable separately if anyone finds it useful. It's information is available
in the window anyhow. So it's superfluous from my point of view. Thanks for your
time!

Kind Regards

Lars
Comment 18 iucounu 2010-12-07 00:19:26 UTC
This feature is inane, superfluous and extremely annoying. At this stage in my
OO evolution I would like to retain tool tips, but not at the expense of
frustration every time I scroll. This issue has been on the books since
2004...how many disgruntled users over how many years does it take to effect a
small and sensible change? 
Comment 19 keithburgoyne 2011-02-18 15:13:44 UTC
I very much hope that this can be resolved soon. It's a fairly useless feature,
and it inhibits reading of the document while scrolling.
Comment 20 akrouskop 2011-03-11 18:32:26 UTC
just another who finds this "feature" rather useless and highly annoying
Comment 21 nicolas.james 2011-03-18 13:51:54 UTC
I agree totally with this request. The tooltip while scrolling is useless, redundant with the status bar. It is annoying and perturbing while displaying a document. I don't understand why it is not already possible to deactivate this feature...
Comment 22 ottadini 2011-05-10 01:19:28 UTC
This bug should be squashed like the annoying itching twitching flittering tittering thing it is.

Actually I'm a sensitive soul with a soft heart and can't imagine squashing bugs indiscriminately, but this one really deserves the 10 minutes' of developer effort it would take to eliminate it. 

Perhaps a developer could help us all out by posting the relevant section of code that is responsible for it? I have never worked with any OOo code, but perhaps I can take a hatchet to my own source files and compile a 'fixed' version for myself.
Comment 23 lxtips 2011-05-30 10:46:24 UTC
If this isn't a bug then please move this thread. 7 years is pointless.
Comment 24 jenf 2011-07-14 17:56:12 UTC
Please disable this annoying tooltip completely, or at least add an option to hide it.
This is the very most annoying thing on OpenOffice, every time I scroll it bugs me and it looks very disgusting on my netbook.
It is very useless also! No other application bugs with an annoying tooltip while scrolling.
Comment 25 issues.apache 2012-07-16 12:28:44 UTC
C'mon please disable this annoying tooltip!
8 years of making people angry when scrolling in Open-/LibreOffice, it's now on time to fix this bug!

Every time I scroll it freaks me out! So ugly, useless and confusing.
Comment 26 tarverator 2012-07-16 12:39:43 UTC
It really is annoying. Why is this so hard to fix? Surely it is a one-line code change. KILL IT!
Comment 27 Ariel Constenla-Haile 2012-07-17 16:44:49 UTC
(In reply to comment #26)
> Surely it is a one-line code change. 

No, it's more than one line:

IMPL_LINK( SwView, ScrollHdl, SwScrollbar *, pScrollbar )
in main/sw/source/ui/uiview/viewport.cxx
http://svn.apache.org/viewvc/incubator/ooo/trunk/main/sw/source/ui/uiview/viewport.cxx?revision=1198305&view=markup#l700

> It really is annoying. Why is this so hard to fix? 
> KILL IT!

This issue has 58 votes, Apache OpenOffice 3.4.0 has 8 million downloads; it is rather hard to measure how annoying is this bug for all the users. So killing this feature isn't the right way to go.

The tooltips for the content in Writer can be turned off by a setting on the configuration registry: /org.openoffice.Writer/Content/Display/PreventTips
This settings is not available from the "Tools" - "Options..." dialog, you have to use a macro to turn it on/off.

Something similar can be implemented for the tooltips in the scroll bar. It has to be discussed if:

- showing scroll bar tips is or and off by default
- this option is configurable with the "Tools" - "Options..." dialog
Comment 28 lacos 2012-07-17 20:44:05 UTC
(In reply to comment #27)

> This issue has 58 votes, Apache OpenOffice 3.4.0 has 8 million downloads; it
> is rather hard to measure how annoying is this bug for all the users.

How do the 53 votes compare to the number of votes other bugs get (bugs that are fixed)? "Don't outrun the bear, outrun another hunter."

Thanks.
Comment 29 Ariel Constenla-Haile 2012-07-18 04:02:33 UTC
(In reply to comment #28)
> > This issue has 58 votes, Apache OpenOffice 3.4.0 has 8 million downloads; it
> > is rather hard to measure how annoying is this bug for all the users.
> 
> How do the 53 votes compare to the number of votes other bugs get (bugs that
> are fixed)?

IMO a comparison here is pointless, because there are bugs that get fixed with zero votes.
May be the question should be: does the number of votes have any influence in the bug being fixed? 
You can perform a search in bugzilla by Votes: (is greater than) 50 AND Status: (is not equal to) FIXED and you'll find bugs with more than 100 votes and older that this one (See bug 3395 for example), then you can draw your own conclusions.
Comment 30 ottadini 2012-07-18 05:05:44 UTC
(In reply to comment #27)
> The tooltips for the content in Writer can be turned off by a setting on the
> configuration registry: /org.openoffice.Writer/Content/Display/PreventTips
> This settings is not available from the "Tools" - "Options..." dialog, you
> have to use a macro to turn it on/off.

Ariel (or anyone else who can help),
Can you please provide us with the code for such a macro? Or, a link to somewhere it is archived? I am not familiar with the macro language, and it would take a long time for me to work it out. 

It would be greatly appreciated by me, and others I'm sure. It may also help to avert future angry additions to this bug report. 

Ben.
Comment 31 Ariel Constenla-Haile 2012-07-18 05:34:22 UTC
(In reply to comment #30)
> (In reply to comment #27)
> > The tooltips for the content in Writer can be turned off by a setting on the
> > configuration registry: /org.openoffice.Writer/Content/Display/PreventTips
> > This settings is not available from the "Tools" - "Options..." dialog, you
> > have to use a macro to turn it on/off.
> 
> Ariel (or anyone else who can help),
> Can you please provide us with the code for such a macro? Or, a link to
> somewhere it is archived? I am not familiar with the macro language, and it
> would take a long time for me to work it out. 
> 
> It would be greatly appreciated by me, and others I'm sure. It may also help
> to avert future angry additions to this bug report. 

Note that as stated in bug 120300 the property isn't document and may change in the future, in fact I'm proposing a new name: "ShowContentTips".

I'll attach a document with a macro to toggle this setting. Note that "PreventTips" set to true will prevent showing a help balloon when you place the mouse pointer over a document content, for example: when the mouse is over an hyperlink, the balloon usually says "Ctr-click to open hyperlink: <URL>".
Comment 32 Ariel Constenla-Haile 2012-07-18 05:39:10 UTC
Created attachment 78674 [details]
Writer document with macros to toggle these settings

The macro ModuleViewSettings applies changes at MODULE level, for every Writer document.

The macro *toggles* the property's value.
Comment 33 rgb 2012-07-19 20:30:35 UTC
Created attachment 78693 [details]
Screen shot showing the misplaced tool tip

There is also an inconsistency on the tool tip position when scrolling if the document contains headings: if the mouse pointer is on the left of the page the tool tip shows near the scroll bar but if the mouse pointer is near the right margin the tool tip shows on mouse position (see attached screen shot).

If the document contains no headings, the tool tip always shows near the scroll bar. 

This behaviour is distracting when you are scanning the document because the tool tip comes on top of the content, partially hiding it. 

Tested on AOO341m1(Build:9591) - Rev1359641 ES localization.
Comment 34 Regina Henschel 2012-07-19 22:42:15 UTC
If you scroll with the mouse wheel, the tooltip is shown on the right side of the cursor. If the cursor is so near to the right border, that there is not enough place for the tooltip, then the tooltip is shown on the left side of the cursor.

If you scroll with the slider of the scrollbar on the right side, then the tooltip is left from the slider.
Comment 35 Ariel Constenla-Haile 2012-12-11 04:33:46 UTC
Fixed on trunk with revision 1419993
Comment 36 ottadini 2012-12-11 05:34:22 UTC
(In reply to comment #35)
> Fixed on trunk with revision 1419993

:):):)
Comment 37 SVN Robot 2012-12-11 08:50:01 UTC
"arielch" committed SVN revision 1419993 into trunk:
i25945 - Allow disabling scrollbar tips by API and configuration
Comment 38 tarverator 2012-12-11 15:29:23 UTC
Thank you!