Issue 120079 - [From Symphony] There is a memory leak in function framework::Frame::initialize
[From Symphony] There is a memory leak in function framework::Frame::initialize
Status: CLOSED FIXED
Product: performance
Classification: Code
Component: code
AOO 3.4.0
All All
: P3 normal (vote)
: AOO 4.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks: 120975 121366
  Show dependency treegraph
 
Reported: 2012-06-25 09:00 UTC by ChaoHuang
Modified: 2013-02-16 09:12 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
for file "main/framework/inc/services/frame.hxx" and "main/framework/source/services/frame.cxx" (2.39 KB, patch)
2012-06-25 09:08 UTC, ChaoHuang
chao.dev.h: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description ChaoHuang 2012-06-25 09:00:08 UTC
Steps to reproduce the defect:
1) Launch Aoo3.4
2) Quit from Aoo3.4

Defect : There is a memory leak in function framework::Frame::initialize
Comment 1 ChaoHuang 2012-06-25 09:04:42 UTC
In function framework::Frame::initialize, an unname WindowCommandDispatch object is created on heap. But it will not be released in destructor. So it is a memory leak. The solution is to record the unname object with member data in class framework::Frame and free it in destructor.
Comment 2 ChaoHuang 2012-06-25 09:08:34 UTC
Created attachment 78462 [details]
for file "main/framework/inc/services/frame.hxx" and "main/framework/source/services/frame.cxx"
Comment 3 hdu@apache.org 2012-06-25 11:19:04 UTC
Applied as 0. Thanks for the patch!
Comment 4 Yan Ji 2012-11-30 04:46:47 UTC
Since last SVT(r1400866) shows there is no memory leak, so close this defect as resolved.