Issue 119514 - [From Symphony]Item lists are incorrectly imported by Symphony.
[From Symphony]Item lists are incorrectly imported by Symphony.
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 08:29 UTC by Terry Yang
Modified: 2012-10-18 06:29 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Sample file (693.00 KB, application/vnd.ms-excel)
2012-05-29 08:36 UTC, Terry Yang
no flags Details
UT file for this issue (7.00 KB, application/vnd.ms-excel)
2012-09-21 05:45 UTC, Jianyuan Li
no flags Details
Patch for this issue (1.21 KB, patch)
2012-09-21 05:45 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Terry Yang 2012-05-29 08:29:31 UTC
1. Launch Symphony2.0 then open the attached sample file.
2. Click down arrow of "Brand"cell button.
3. Check the list items     
	
Actual Result:"#N/A" is selected.

Expect Result:Same as in excel,"#N/A" is unselected.
Comment 1 Terry Yang 2012-05-29 08:36:18 UTC
Created attachment 77721 [details]
Sample file
Comment 2 Jianyuan Li 2012-06-13 02:31:53 UTC
I am investigating this issue.
Comment 3 Jianyuan Li 2012-09-21 05:44:14 UTC
Root cause: Error string is not handled when import.
Resolution: Handle error strings. If the strings can be obtained, its property "Visible"(Checked) will be correctly indirectly.
Comment 4 Jianyuan Li 2012-09-21 05:45:05 UTC
Created attachment 79596 [details]
UT file for this issue
Comment 5 Jianyuan Li 2012-09-21 05:45:35 UTC
Created attachment 79597 [details]
Patch for this issue
Comment 6 sunying 2012-09-25 02:18:38 UTC
patch looks good, reviewed.
Comment 7 Jianyuan Li 2012-09-25 05:57:43 UTC
Committed in revision 1389719
Comment 8 Jianyuan Li 2012-09-25 06:00:14 UTC
Fixed.
Comment 9 Terry Yang 2012-09-27 09:17:56 UTC
Verify fixed on AOO 3.5 Trunk r1390312
Comment 10 Shenfeng Liu 2012-10-18 06:29:29 UTC
Update Target Milestone to AOO 3.5.0.