Issue 118859 - sw: Incorrect text wrapping around drawing shapes (depending on zoom level)
sw: Incorrect text wrapping around drawing shapes (depending on zoom level)
Status: RESOLVED DUPLICATE of issue 100684
Product: Writer
Classification: Application
Component: code
OOo 3.4 Beta
PC All
: P5 normal (vote)
: ---
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-31 20:06 UTC by openoffice
Modified: 2012-06-25 19:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Patch to fix the problem in LibreOffice (1.29 KB, application/octet-stream)
2012-01-31 20:06 UTC, openoffice
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description openoffice 2012-01-31 20:06:47 UTC
Created attachment 77180 [details]
Patch to fix the problem in LibreOffice

When using a drawing shape with contour page wrapping, the text is wrapped
around a "virtual object" left or right of the shape after changing zoom level
and entering page preview (or printing / PDF export).

Steps to reproduce: 
1. Add some text to a writer document
2. Draw a rectangle somewhere (right half of page) on the text
3. Switch the rectangle's wrapping to page wrap (this will automatically enable contour wrapping)
4. Zoom out a bit (make sure the entire page width is visible, and the page is centered)
5. Switch to page preview

Expected result:
Text wraps around the rectangle

Actual Result: 
Text wraps around a white space left of the rectangle


This is caused by a missing call to ClrContourCache( pObj ) in
    /sw/source/core/layout/pagechg.cxx:
    void lcl_MoveAllLowerObjs( SwFrm* pFrm, const Point&  rOffset )
in the
    else if ( pAnchoredObj->ISA(SwAnchoredDrawObject) )
case (in the if case, pFlyFrm->NotifyDrawObj() calls ClrContourCache).

The attached patch was created for LibreOffice, but the affected code in OOo looks unchanged.
Comment 1 openoffice 2012-01-31 20:09:20 UTC
This patch will likely also fix bug 100684.
Comment 2 openoffice 2012-06-25 19:27:21 UTC
Duplicate of bug 100684

*** This issue has been marked as a duplicate of issue 100684 ***