Issue 108675 - Locale data for Latgalian_Latvia [ltg-LV]
Locale data for Latgalian_Latvia [ltg-LV]
Status: VERIFIED FIXED
Product: Internationalization
Classification: Code
Component: localedata
OOO320m9
All All
: P3 trivial (vote)
: ---
Assigned To: stefan.baltzer
issues@l10n
:
: 94308 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-26 12:42 UTC by jancs
Modified: 2013-08-07 15:02 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
locale data for Latgalian language (13.09 KB, text/plain)
2010-01-26 12:43 UTC, jancs
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jancs 2010-01-26 12:42:42 UTC
Hi!

Please add locale data for Latgalian language. 

Locale data can be found here:
http://www.it46.se/localegen/locale/1264507821_ltg_LV.xml
Comment 1 jancs 2010-01-26 12:43:26 UTC
Created attachment 67421 [details]
locale data for Latgalian language
Comment 2 ooo 2010-01-26 13:32:30 UTC
Thank you for your contribution.
This locale data file was generated using the locale data generator at
http://www.it46.se/localegen/, so if you do not plan further
contributions to the OOo code base that would need a signed SCA (see
http://wiki.services.openoffice.org/wiki/Sun_Contributor_Agreement ) we
may as well make use of the joint copyright agreement as lined out in
http://www.it46.se/localegen/copyright.php

@it46: For this I formally ask Alberto Escudero-Pascual to contribute
the attached locale data file to the OOo code base under the JCA/SCA he
signed.

Thanks
  Eike
Comment 3 jancs 2010-01-27 08:26:34 UTC
Please feel free to do with created locale files whatever is necessary to
achieve the goal. 
I gladly grant Alberto Escudero-Pascual rights to contribute it to OpenOffice.org.
Comment 4 it46 2010-01-27 10:08:16 UTC
it46->er: The locale has been completed via localegen and joint copyright
agreement has been accepted.
Comment 5 jancs 2010-01-27 14:31:56 UTC
What is the approximate date of OOo 3.3 release?
If I'd want to check locale in action before official release, when could some
development build become available including ltg?
Comment 6 erack 2010-02-21 00:24:57 UTC
In cws locales33:

changeset 0034b9798c29 http://hg.services.openoffice.org/cws/locales33/changeset/0034b9798c29
M i18npool/inc/i18npool/lang.h
M i18npool/source/isolang/isolang.cxx
M i18npool/source/localedata/data/localedata_euro.map
M i18npool/source/localedata/data/makefile.mk
M i18npool/source/localedata/localedata.cxx
M svtools/source/misc/langtab.src
A i18npool/source/localedata/data/ltg_LV.xml


#define LANGUAGE_USER_LATGALIAN             0x064B
mapping to ltg-LV

Note: adapted currency format code particle [$Ls-426] to [$Ls-64B]

When compiling the locale data I got

Error: ThousandSeparator is an ' ' ordinary space, this should be a non-breaking space U+00A0 instead.
Warning: Don't forget to adapt corresponding FormatCode elements when changing separators.

I changed the separator to non-breaking space where applicable.


Warning: FormatCode formatindex="12" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="13" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="14" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="15" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="17" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.

I changed the negative format codes from
(# ##0,00 [CURRENCY])
to
-# ##0,00 [CURRENCY]
as in lv_LV.xml, though note that lv_LV does not have a blank between amount and currency symbol.


Warning: QuotationStart and QuotationEnd are both ASCII characters. Not necessarily an error, but unusual.
Warning: DoubleQuotationStart and DoubleQuotationEnd are both ASCII characters. Not necessarily an error, but unusual.
Warning: QuotationStart equals QuotationEnd. Not necessarily an error, but unusual.
Warning: DoubleQuotationStart equals DoubleQuotationEnd. Not necessarily an error, but unusual.

Usually typographic quotation marks are used, there are several, could you
please pick the correct ones? I'd need the change as soon as possible.

    Hex        HTML    Character   Unicode
   0xAB     «    "«"         LEFT-POINTING DOUBLE ANGLE QUOTATION MARK
   0xBB     »    "»"         RIGHT-POINTING DOUBLE ANGLE QUOTATION MARK
 0x2018     ‘    "‘"         LEFT SINGLE QUOTATION MARK
 0x2019     ’    "’"         RIGHT SINGLE QUOTATION MARK
 0x201A     ‚    "‚"         SINGLE LOW-9 QUOTATION MARK
 0x201B     ‛    "‛"         SINGLE HIGH-REVERSED-9 QUOTATION MARK
 0x201C     “    "“"         LEFT DOUBLE QUOTATION MARK
 0x201D     ”    "”"         RIGHT DOUBLE QUOTATION MARK
 0x201E     „    "„"         DOUBLE LOW-9 QUOTATION MARK
 0x201F     ‟    "‟"         DOUBLE HIGH-REVERSED-9 QUOTATION MARK
 0x2039    ‹    "‹"         SINGLE LEFT-POINTING ANGLE QUOTATION MARK
 0x203A    ›    "›"         SINGLE RIGHT-POINTING ANGLE QUOTATION MARK


CWS locales33 is planned to go into QA Mar-02 and will probably be in a master
build 2 weeks after. You can apply the changeset given above to your local
build to check things earlier.
Comment 7 jancs 2010-02-21 06:49:08 UTC
Hi!

Please feel free to make adjustments to the locale ltg_LV where needed to be the
same as in lv_LV.  This relates to the currency handling and quotation marks
Comment 8 jancs 2010-02-21 06:52:34 UTC
As i am not familiar with building of OO at all, will the mentioned snapshot be
available as pre-built development release after two weeks?
Comment 9 erack 2010-02-21 22:55:03 UTC
Adapted quotation marks and currency formats to lv_LV.
Added UnicodeScript 2 to LC_INDEX section.

In cws locales33:

changeset 6132c74bbe8d
http://hg.services.openoffice.org/cws/locales33/changeset/6132c74bbe8d
M i18npool/source/localedata/data/ltg_LV.xml

You can observe the progress and possible integration date of CWS locales33 at
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Flocales33


However, I have some doubts about IndexKey A-Ž, that may or may not produce the
desired result, it will sort index table entries according to Unicode code
points for all letters between A and Ž. lv_LV for example instead has
A-Y Č Ģ Ķ Ļ Ņ Š Ž

And shouldn't
  <LC_OutLineNumberingLevel ref="en_US"/>
be
  <LC_OutLineNumberingLevel ref="lv_LV"/>
instead?

And maybe even
  <LC_NumberingLevel ref="lv_LV"/>
instead of defining own numbering levels that are almost identical to en_US
except the first two?
Comment 10 jancs 2010-02-22 08:53:50 UTC
I do not recall myself defining numbering levels, but - OK - please make them
similar to lv_LV.

Note: in Latvian for indexing are used Latin characters without diacritical
marks - i.e. letters Ā, Ē, Ī, Ū, Ō, Č, Ģ, Ķ, Ļ, Ņ, Š, Ž are not used. At least -
I hadn't seen.
Comment 11 erack 2010-02-24 19:49:42 UTC
changeset d7dadcefe42a
http://hg.services.openoffice.org/cws/locales33/changeset/d7dadcefe42a
M i18npool/source/localedata/data/ltg_LV.xml

Changed both numbering levels to refer lv_LV.

Note: the initial 'lv' IndexKey data was setup according to the ICU/CLDR
collation, see also http://unicode.org/repos/cldr-tmp/trunk/diff/summary/lv.html
entry 2455, exemplarCharacters, and
http://demo.icu-project.org/icu-bin/locexp?d_=en&_=lv
There is no data for 'ltg'.
Comment 12 jancs 2010-02-24 21:59:38 UTC
Regarding ICU/CLDR and ltg - I see, there is the next task to be done to create
a locale ltg_LV with unicode.org. I hope it not influences inclusion of ltg in
OO sources.

Regarding last changes in ISO 639-3, under macro language lav there are two
languages - Latvian Standard (code lvs, in ISO639-1 - lv) and Latgalian (code
ltg). So, from this January exists lv_LV (which denotes Latvian Standard) and
ltg_LV (see, http://www.sil.org/iso639-3/documentation.asp?id=ltg and related
documents)

Comment 13 erack 2010-02-26 16:39:23 UTC
No, CLDR does not interfere with OOo locales. To the contrary, CLDR data is used
in ICU that in turn is used in OOo and may add functionality like locale
dependent collation if needed. Alberto from it46.se can contribute locale data
files generated with the it46 generator to the CLDR for consideration. However,
that should include all fixes we did here so you should generate a new locale
data file at it46, check the current OOo ltg_LV.xml tip at
http://hg.services.openoffice.org/cws/locales33/file/tip/i18npool/source/localedata/data/ltg_LV.xml
for reference.
Comment 14 ooo 2010-03-06 00:10:05 UTC
Reassigning to QA for verification.
Comment 15 stefan.baltzer 2010-03-12 15:41:05 UTC
Verified in CWS locales33.
Comment 16 caolanm 2010-08-24 09:38:36 UTC
*** Issue 94308 has been marked as a duplicate of this issue. ***