Issue 100123 - Allow to turn OOo-file locking off.
Allow to turn OOo-file locking off.
Status: CLOSED FIXED
Product: General
Classification: Code
Component: code
DEV300m41
All All
: P3 trivial (vote)
: OOo 3.2
Assigned To: thorsten.martens
issues@framework
:
: 97139 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 12:52 UTC by mikhail.voytenko
Modified: 2011-06-28 10:59 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
The configuration file that turn OOo lockiing off. (960 bytes, text/plain)
2009-06-02 13:54 UTC, mikhail.voytenko
no flags Details
the diff for Common.xcu (394 bytes, text/plain)
2009-06-02 13:56 UTC, mikhail.voytenko
no flags Details
Ups, the previous diff is reversed one. This is the correct one. (394 bytes, text/plain)
2009-06-02 13:59 UTC, mikhail.voytenko
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mikhail.voytenko 2009-03-11 12:52:31 UTC
It looks to make sense to allow to turn off the OOo file locking based on the
lock file. In some cases ( for example network outage ) the lock file can not be
removed.

Additionally there are some exotic cases when a file can be created but can not
be removed. From my knowledge it is possible only on Windows currently.

Bases on the mentioned above it could make sense to allow to ignore the lock
file. Showing the dialog that would allow the user to ignore the lock would
probably be too much for a normal user. The decision should be taken by the
system administrator or somebody who is skilled enough.

Thus, we need the same solution as in case of turning off the system file
locking. There should be an OOo-registry entry that would allow to turn
lockfile-based locking mechanics off.
Comment 1 mikhail.voytenko 2009-03-31 14:09:26 UTC
Fixed in fwk103.
Comment 2 mikhail.voytenko 2009-05-18 10:47:28 UTC
mav->tm: Please verify the issue.
The OOo-locking mechanics can now be turned on/off using the configuration entry
/org.openoffice.office.Common/Misc/UseDocumentOOoLockFile

When OOo-locking mechanics is turned off, the lock file is still created, but
only as a help-file. Existence of OOo-lock file does not prevent document
opening in this mode.

In addition to testing of this feature, please use the standard test-plan you
have used to test OOo file locking.
Comment 3 mikhail.voytenko 2009-06-02 13:54:47 UTC
Created attachment 62710 [details]
The configuration file that turn OOo lockiing off.
Comment 4 mikhail.voytenko 2009-06-02 13:56:22 UTC
Created attachment 62711 [details]
the diff for Common.xcu
Comment 5 mikhail.voytenko 2009-06-02 13:59:13 UTC
Created attachment 62712 [details]
Ups, the previous diff is reversed one. This is the correct one.
Comment 6 thorsten.martens 2009-06-03 12:56:29 UTC
checked and verified in cws fwk103 -> OK ! 
Comment 7 mikhail.voytenko 2009-08-31 13:20:02 UTC
*** Issue 97139 has been marked as a duplicate of this issue. ***
Comment 8 thorsten.martens 2009-11-17 12:20:57 UTC
closed
Comment 9 brinzing 2011-06-28 10:59:47 UTC
.