ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-985

Test BookieRecoveryTest fails on trunk.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.3.3, 3.4.0
    • Component/s: contrib-bookkeeper
    • Labels:
      None
    • Environment:

      Darwin moststock-lm 9.7.0 Darwin Kernel Version 9.7.0: Tue Mar 31 22:52:17 PDT 2009; root:xnu-1228.12.14~1/RELEASE_I386 i386 (mac).

    • Hadoop Flags:
      Reviewed

      Description

      The unit test fails on trunk on my mac. I think this might be the same on other platforms as well. Ill attach the error logs.

      1. TEST-org.apache.bookkeeper.test.BookieRecoveryTest.txt
        239 kB
        Mahadev konar
      2. ZOOKEEPER-985.patch
        4 kB
        Flavio Junqueira
      3. ZOOKEEPER-985.patch
        4 kB
        Flavio Junqueira

        Activity

        Mahadev konar added a comment -

        logs for the tests.

        Flavio Junqueira added a comment -

        Sounds like a race condition. Checking the logs, I found this:

        2011-02-09 11:07:39,245 - INFO  - [main:BookieRecoveryTest@165] - New bookie on port 5003 has been created.
        2011-02-09 11:07:39,248 - ERROR - [pool-6-thread-1:PerChannelBookieClient$1@129] - Could not connect to bookie: /10.73.146.106:5000
        2011-02-09 11:07:39,248 - WARN  - [pool-6-thread-1:PendingAddOp@115] - Write did not succeed: 1, 10
        2011-02-09 11:07:39,253 - ERROR - [pool-6-thread-1:LedgerHandle@423] - Could not get additional bookie to remake ensemble, closing ledger: 1
        

        We are starting a new bookie, but it sounds like we are not giving enough time for the bookie to start up to be incorporated into the ensemble.

        Flavio Junqueira added a comment -

        I have added some short methods to allow the test to check if a new bookie is running. I haven't been able to reproduce it, but from my understanding from inspecting the logs, it looks like it should solve it.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12471391/ZOOKEEPER-985.patch
        against trunk revision 1069169.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://hudson.apache.org/hudson/job/PreCommit-ZOOKEEPER-Build/138//testReport/
        Findbugs warnings: https://hudson.apache.org/hudson/job/PreCommit-ZOOKEEPER-Build/138//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: https://hudson.apache.org/hudson/job/PreCommit-ZOOKEEPER-Build/138//console

        This message is automatically generated.

        Flavio Junqueira added a comment -

        The failure is not related to this patch.

        Benjamin Reed added a comment -

        looks good flavio. i think the running in Bookie should be volatile.

        Flavio Junqueira added a comment -

        It applies to both trunk and 3.3.

        Flavio Junqueira added a comment -

        ... and almost forgot: thanks for reviewing it, Ben!

        Benjamin Reed added a comment -

        +1 thanx flavio

        Benjamin Reed added a comment -

        Committed revision 1072074. (3.3)
        Committed revision 1072085. (trunk)

        Hudson added a comment -

        Integrated in ZooKeeper-trunk #1102 (See https://hudson.apache.org/hudson/job/ZooKeeper-trunk/1102/)
        ZOOKEEPER-985. Test BookieRecoveryTest fails on trunk. (fpj via breed)


          People

          • Assignee:
            Flavio Junqueira
            Reporter:
            Mahadev konar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development