ZooKeeper
  1. ZooKeeper
  2. ZOOKEEPER-902

Fix findbug issue in trunk "Malicious code vulnerability"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.4.0
    • Fix Version/s: 3.4.0
    • Component/s: quorum, server
    • Labels:
      None

      Description

      https://hudson.apache.org/hudson/view/ZooKeeper/job/ZooKeeper-trunk/970/artifact/trunk/findbugs/zookeeper-findbugs-report.html#Warnings_MALICIOUS_CODE

      Malicious code vulnerability Warnings

      Code Warning
      MS org.apache.zookeeper.server.quorum.LeaderElection.epochGen isn't final but should be

      1. ZOOKEEPER-902.patch
        2 kB
        Patrick Hunt
      2. ZOOKEEPER-902.patch
        7 kB
        Flavio Junqueira
      3. ZOOKEEPER-902.patch
        8 kB
        Flavio Junqueira
      4. ZOOKEEPER-902.patch
        10 kB
        Patrick Hunt
      5. ZOOKEEPER-902.patch
        10 kB
        Patrick Hunt
      6. ZOOKEEPER-902.patch
        11 kB
        Flavio Junqueira
      7. ZOOKEEPER-902.patch
        18 kB
        Flavio Junqueira
      8. ZOOKEEPER-902.patch
        18 kB
        Flavio Junqueira
      9. ZOOKEEPER-902.patch
        20 kB
        Patrick Hunt

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              Flavio Junqueira
              Reporter:
              Patrick Hunt
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development