Uploaded image for project: 'ZooKeeper'
  1. ZooKeeper
  2. ZOOKEEPER-805

four letter words fail with latest ubuntu nc.openbsd

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 3.3.1, 3.4.0
    • Fix Version/s: 3.4.6
    • Component/s: documentation, server
    • Labels:
      None

      Description

      In both 3.3 branch and trunk "echo stat|nc localhost 2181" fails against the ZK server on Ubuntu Lucid Lynx.

      I noticed this after upgrading to lucid lynx - which is now shipping openbsd nc as the default:

      OpenBSD netcat (Debian patchlevel 1.89-3ubuntu2)

      vs nc traditional

      [v1.10-38]

      which works fine. Not sure if this is a bug in us or nc.openbsd, but it's currently not working for me. Ugh.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                phunt Patrick Hunt
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: